Lemonade Line

题目描述

It's a hot summer day out on the farm, and Farmer John is serving lemonade to his N cows! All N cows (conveniently numbered 1…N) like lemonade, but some of them like it more than others. In particular, cow ii is willing to wait in a line behind at most wiwi cows to get her lemonade. Right now all NN cows are in the fields, but as soon as Farmer John rings his cowbell, the cows will immediately descend upon FJ's lemonade stand. They will all arrive before he starts serving lemonade, but no two cows will arrive at the same time. Furthermore, when cow ii arrives, she will join the line if and only if there are at most wiwi cows already in line.
Farmer John wants to prepare some amount of lemonade in advance, but he does not want to be wasteful. The number of cows who join the line might depend on the order in which they arrive. Help him find the minimum possible number of cows who join the line.

输入

The first line contains N, and the second line contains the N space-separated integers w1,w2,…,wN. It is guaranteed that 1≤N≤105, and that 0≤wi≤109 for each cow i.

输出

Print the minimum possible number of cows who might join the line, among all possible orders in which the cows might arrive.

样例输入

5
7 1 400 2 2

样例输出

3

提示

In this setting, only three cows might end up in line (and this is the smallest possible). Suppose the cows with w=7 and w=400 arrive first and wait in line. Then the cow with w=1 arrives and turns away, since 2 cows are already in line. The cows with w=2 then arrive, one staying and one turning away.

题解:水题,每个奶牛可以容纳前面同类的数量已经给出,让队列中的奶牛数量尽可能少,所以从大到小排序,让容纳多的奶牛站在前面。

#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
bool cmp(int x,int y)
{
    return x>y;
}
int main()
{
    int a[100005],i,j,k,n,sum=0;
    cin>>n;
    for(i=0;i<n;i++)
    {
        cin>>a[i];
    }
    sort(a,a+n,cmp);
    for(i=0;i<n;i++)
    {
        if(a[i]>=sum)
        {
            sum++;
        }
        else
        {
            break;
        }
    }
    cout<<sum<<endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值