- 时间:200ms
- 内存:131072K
Coconut is Captain Gangplank's favourite fruit. That is why he needs to drink coconut juice from b coconuts each day.
On his next trip, he would pass through N citis.
His trip would begin in the 1-st city and end in the N-th city.
The journey from the i-th city to the (i+1)-th city costs Di days.
Initially, there is no coconut on his ship. Fortunately, he could get supply of Ci coconuts from the i-th city.
Could you tell him, whether he could drink coconut juice every day during the trip no not?
Input Format
The first line contains an integer T, indicating that there are T test cases.
For each test case the first line contains two integers N and b as described above.
The second line contains N integers C1,C2,⋯,CN.
The third line contains N−1 integers D1,D2,⋯,DN−1.
All integers in the input are less than 1000.
Output Format
For each case, output Yes if Captain Gangplank could drink coconut juice every day, and otherwise output No.
样例输入
2
4 1
3 2 1 4
1 2 3
4 2
2 4 6 8
3 2 1
样例输出
Yes
No
#include <iostream>
#include<stdio.h>
using namespace std;
int main()
{
int n,b,t,c[1010],d[1010],sum;
scanf("%d",&t);
while(t--)
{
bool t=false;
scanf("%d %d",&n,&b);
for(int i=1;i<=n;i++)
scanf("%d",&c[i]);
for(int i=1;i<n;i++)
scanf("%d",&d[i]);
sum=0;
for(int i=1;i<n;i++)
{
sum+=c[i];
sum-=d[i]*b;
if(sum<0)
{
t=true;
break;
}
}
if(t)
printf("No\n");
else
printf("Yes\n");
}
return 0;
}