HDU 1048-The Hardest Problem Ever

The Hardest Problem Ever

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29157    Accepted Submission(s): 13639


Problem Description
Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked. 
You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite: 

Cipher text
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U 

Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.
 

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase. 

A single data set has 3 components: 

Start line - A single line, "START" 

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar 

End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT".
 

Output
For each data set, there will be exactly one line of output. This is the original message by Caesar.
 

Sample Input
  
  
START NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX END START N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ END START IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ END ENDOFINPUT
 

Sample Output
  
  
IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

题意:

给你一个字符串,里面的字母‘A’-‘Z’需要被编译,编译规则是

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z(该26个字母对应的字母是下面的字母)

V W X Y Z A B C D E F G H I J K L M N O P Q R S T U 

其他的字符不需要被编译,每个需要编译的字符串长度最多为200,在该字符串的开始有“START”标志,结尾有“END”标志,当出现“ENDOFINPUT”标志时,表示结束。

分析:

本题只要将对应的编码打表列出即可,但是我们知道scanf在读入字符串的时候,读入不了空格,所以我们采用gets输入,但是在while循环里输入的方式也不能用scanf,得用gets。原因是gets()从标准输入设备读取字符串,以回车结束读取,使用‘\0’结尾,回车符‘\n’被舍弃没有遗留在缓冲区。而scanf()以空格或回车符结束读取,空格或回车符会遗留在缓冲区。


#include <iostream>
#include<stdio.h>
#include<string>
#include<string.h>
using namespace std;

int main()
{
    char m[205],n[205];
    char s[27]={'V','W','X','Y','Z','A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U'};
    while(gets(m))
    {
        if(strcmp(m,"START")==0)
        {
            gets(n);
            for(int i=0;i<strlen(n);i++)
            {
                if(n[i]>='A'&&n[i]<='Z')
                    n[i]=s[n[i]-'A'];
            }
            puts(n);
        }
        else if(strcmp(s,"ENDOFINPUT")==0)
            break;
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值