HDU 1078-FatMouse and Cheese

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12003    Accepted Submission(s): 5078


题目链接: 点击打开链接

Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
  
  
37
 

题意:

在一个正方形的网格中,有个老鼠在每个网格中存有不同数量的奶酪,老鼠可以水平或垂直移动,但是在奶酪的附近有对老鼠有生命威胁的东西,所以老鼠一次最多跳 k 格,但是老鼠下一次去的网格中得到的奶酪的数量一定要比当前位置的奶酪的数量多,让你求老鼠最多可以在这个网格中吃到的奶酪数量。


分析:

本题我们用搜索,这题是在练动态规划的专题里,但我感觉非常像一个搜索题。



#include<iostream>
#include<stdio.h>
#include<string>
#include<string.h>
using namespace std;

int dp[105][105];
int s[105][105];
int n,k;

int x[4]={0,1,0,-1};
int y[4]={1,0,-1,0};

int dfs(int p,int q)
{
    if(dp[p][q])///如果该格已经搜过周围了,说明里面存有数值,并且是最优解,故不用再往下搜了
        return dp[p][q];
    int sum=0,ans;
    int xx,yy;
    for(int i=0;i<4;i++)
    {
        for(int j=1;j<=k;j++)
        {
            xx=p+j*x[i];
            yy=q+j*y[i];
            if(xx>=0&&xx<n&&yy>=0&&yy<n&&s[p][q]<s[xx][yy])
            {
                ans=dfs(xx,yy);
                if(sum<ans)
                    sum=ans;///求出周围网格中的最大奶酪数量
            }
        }
    }
    dp[p][q]=sum+s[p][q];///当前格子里所获得的最大的奶酪数量
    return dp[p][q];
}

int main()
{
    while(~scanf("%d %d",&n,&k))
    {
        if(n==-1&&k==-1)
            break;
        memset(dp,0,sizeof(dp));///dp要初始化全部刷为0
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                scanf("%d",&s[i][j]);
            }
        }
        dfs(0,0);
        printf("%d\n",dp[0][0]);
    }
   return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值