HDU 1078 FatMouse and Cheese(动态规划)

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food. 

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole. 

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
Sample Output
37

 【题解】

   题意为从n*n矩阵的左上角出发,找一条最长上升子序列,此序列上的数字和即为所求,用记忆化搜索去搜就好了,只是有个条件限制,就是每次最多只能走k步,所以我们可以把搜索的范围限制在当前点前后左右<=k的范围内就好了,要注意搜索顺序,上到下,左到右,我第一次写把方向搞反了,WA了好几次,汗~~

 【AC代码】

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=105;
int n,k,ans;
int map[N][N];
int dp[N][N];

int check(int i,int j)
{
    if(dp[i][j])
        return dp[i][j];
    int aa=i-k;
    if(aa<0) aa=0;
    int b=i+k;
    if(b>=n) b=n-1;
    int c=j-k;
    if(c<0) c=0;
    int d=j+k;
    if(d>=n) d=n-1;
    int maxn=0;

    for(int p=aa;p<=b;++p)
    {
        if(map[i][j]<map[p][j])
        {
          int ss=check(p,j);
          if(maxn<ss)
              maxn = ss;
        }
    }

    for(int p=c;p<=d;++p)
    {
        if(map[i][j]<map[i][p])
        {
            int ss= check(i,p);
            if(ss>maxn)
                maxn=ss;
        }
    }
    dp[i][j]=maxn+map[i][j];
    return dp[i][j];
}

int main()
{
    while(~scanf("%d%d",&n,&k))
    {
      if(n==-1&&k==-1)
          break;
      for(int i=0;i<n;++i)
      {
        for(int j=0;j<n;++j){
            scanf("%d",&map[i][j]);
            dp[i][j]=0;
        }
      }
      printf("%d\n",check(0,0));
    }
    return 0;
}
 才开始写动态规划 ,代码可能不是很完美,谅解~~

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值