HDU 1021-Fibonacci Again

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 67894    Accepted Submission(s): 31346



题目链接:点击打开链接


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
 
 
0 1 2 3 4 5
 

Sample Output
 
 
no no yes no no no


题意:

F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).给你一个 n ,让你求 F[n] 是否能整除 3 ,如果能整除,就输出 yes ,如果不能整除,就输出 no.


分析:

找规律,在纸上写出十几个数即可得出规律,规律发现,当 n 等于 0, 1,时,是 no ,n 等于 2 时,是 yes ,然后下一个 yes  就是前一个 yes 对应的 n 加上 4 的结果,所以就出来了。。。。


#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0||n==1)
            printf("no\n");
        else if(n==2)
            printf("yes\n");
        else
        {
            int m=2;
            int bj=4;
            int p=0;
            while(m<=n)
            {
                if(m==n)
                {
                    printf("yes\n");
                    p=1;
                    break;
                }
                else
                {
                    m+=bj;
                }
            }
            if(p==0)
                printf("no\n");
        }
    }
    return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值