HDU 1087-Super Jumping! Jumping! Jumping!

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45922    Accepted Submission(s): 21281


题目链接:点击打开链接


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
 
 
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
 
 
4 10 3


题意:

就是给你 N 个棋子,这 N 个棋子的排列是一个不可变的序列,每个棋子都有一个价值,你可以任选一个任选一个棋子开始,然后你往后只能走比该棋子价值大的棋子,不能走回头路,问你能得到的最大的价值是多少。


分析:

在杭电用C++提交本题,总是这个错误,用G++交就可以,按说不应该识别不了max呀,我有头文件的呀。好奇怪,有知道的宝宝告诉我一下。

0_0_24400737_3645.cpp
0_0_24400737_3645.cpp(25) : error C3861: “max”:  找不到标识符
0_0_24400737_3645.cpp(32) : error C3861: “max”:  找不到标识符0_0_24400737_3645.cpp

本题是一个dp题,我们对每一个棋子,都去遍历一遍它之前的比它小的棋子,然后得到该棋子之前能得到的最优解,那么再求得的最优解上加上自身,就是走该棋子能得到的最优解,这样从前到后走一遍,不断的对每一个棋子之前的序列进行遍历求得走该棋子的最优解,存入dp数组里,dp【0】是永远为0的,这样才好进行我们的方法,啊哈哈哈哈。。每次整明白一道dp题都很兴奋,感觉很有意思,但是就是学不会别人的机智。。。


#include <iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;

#define INF 100000005
int s[1005],dp[1005];

int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            scanf("%d",&s[i]);
        int sum;
        for(int i=1;i<=n;i++)
        {
            sum=-INF;///在保证能走s[i],记录s[i]之前序列的最优解
            for(int j=0;j<i;j++)
            {
                if(s[i]>s[j])///保证比s[i]小
                    sum=max(dp[j],sum);
            }
            dp[i]=sum+s[i];///存走到自身这里,并且走自身的最优解
        }
        int ans=-INF;
        for(int i=1;i<=n;i++)
        {
            ans=max(ans,dp[i]);///找出最优解
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值