HDU 3636-Dragon Balls

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7565    Accepted Submission(s): 2800


题目链接:点击打开链接


Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

Input
The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

Sample Input
 
 
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output
 
 
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
 

题意:

最初有 n 个龙珠分别放在对应编号的 n 个城市里面,也就是说,1 号龙珠放在 1 号城市,随着时间的推移,现在有些龙珠被移动了,现在这个孙悟空会告诉你一些关于龙珠的消息,消息类型有两种,第一种是 T A B ,表示的是将 A号龙珠所在城市中的所有的龙珠转移到 B 号城市,Q A,表示的是让你求出三个结果,第一个是 A 号龙珠目前所在的城市编号,第二个是 A 号龙珠目前所在的城市有的所有的龙珠的数量,第三个是 A 号龙珠被转移的次数。


分析:

并查集的思想,你想啊,最初有 n 个龙珠分别放在对应编号的 n 个城市里面,是不是和并查集刚开始对初始上级数组的原理相同,都是设置为自身,看看代码吧,在代码中细说吧!


#include<iostream>
#include<string>
#include<stdio.h>
#include<string>
using namespace std;

int s[10005],sum[10005];

int Pei(int x)///找 x 的上级
{
    if(x==s[x])
        return x;
    return Pei(s[x]);
}

void Find(int a,int b)///合并
{
    int x=Pei(a);
    int y=Pei(b);
    if(x!=y)
    {
        s[x]=y;
        sum[y]+=sum[x];///将 x 城市中的所有龙珠的数量都加到 y 城市里
        sum[x]=0;///然后 x 城市变为0 
    }
}

int main()
{
    int t;
    int n,q;
    char c;
    int a,b;
    scanf("%d",&t);
    for(int j=1;j<=t;j++)
    {
        printf("Case %d:\n",j);
        scanf("%d %d",&n,&q);
        for(int i=1;i<=n;i++)
        {
            s[i]=i;///初始化将上级都设置为自身
            sum[i]=1;///刚开始的时候每个城市的龙珠数量都是1
        }
        while(q--)
        {
            getchar();
            scanf("%c",&c);
            if(c=='T')
            {
                scanf("%d %d",&a,&b);
                Find(a,b);///合并
            }
            if(c=='Q')
            {
                scanf("%d",&a);
                int num=0;
                while(a!=s[a])///求转移的次数
                {
                    num++;
                    a=s[a];
                }
                printf("%d %d %d\n",a,sum[a],num);
            }
        }
    }
    return 0;
}









  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值