POJ 1789-Truck History

Truck History
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 31951 Accepted: 12464


题目链接:点击打开链接


Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

题意:

就是在很久以前,卡车的型号是很单一的,七个字符组成的字符串来表示卡车的型号,随着科技的发展,现在卡车的型号改变了,但新的型号也是在旧的型号的基础之上改变的,现在定义一个改变的原则,就是规定两个卡车的更新距离就是两个卡车的型号不相同的字符个数,这里比较是按照对应位置上的字符,例如 abaaaaa 和 aabaaaa ,这两个卡车的更新距离是 2 ,因为有两个位置上的字符不相同,让你计算出所有卡车之间最小的更新距离 Q,输出 The highest possible quality is 1/Q.


分析:

本题真的是读题半小时还是读的模模糊糊的,英文水平有待提高哇!

最小生成树的变形,假设将每辆卡车都进行一个编号,将两个卡车对应位置上的字母不相同的个数作为他们之间的权值,是不是求出最小生成树,就能就出 Q 的最优解了。


#include <iostream>
#include<stdio.h>
#include<math.h>
#include<string>
#include<string.h>
using namespace std;
#define INF 0x3f3f3f3f
int s[2005][2005];
int n;

void Prim()
{
    int vis[2005],low[2005],minx,bj;
    int sum=0;
    for(int i=1;i<=n;i++)
        low[i]=s[1][i];
    memset(vis,0,sizeof(vis));
    vis[1]=1;
    for(int i=1;i<n;i++)
    {
        minx=INF;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&minx>low[j])
            {
                bj=j;
                minx=low[j];
            }
        }
        vis[bj]=1;
        sum+=minx;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&low[j]>s[bj][j])
                low[j]=s[bj][j];
        }
    }
    printf("The highest possible quality is 1/%d.\n",sum);
}

int main()
{
   char h1[2005][10];
   while(~scanf("%d",&n)&&n)
   {
       getchar();///注意这里要吞掉回车
       for(int i=0;i<=n;i++)
       {
           for(int j=0;j<=n;j++)
           {
               if(i==j)
                    s[i][j]=0;
               else
                s[i][j]=INF;
           }
       }
       for(int i=1;i<=n;i++)
       {
            gets(h1[i]);///输入卡车的型号
            for(int j=1;j<i;j++)///进行权值的计算,存图
            {
                int sum=0;
                for(int k=0;k<7;k++)
                {
                    if(h1[j][k]!=h1[i][k])
                        sum++;
                }
                s[i][j]=s[j][i]=min(s[i][j],sum);
            }
       }
       Prim();
   }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值