POJ - 1789 Truck History(prim最小生成树)

本文介绍了一家名为AdvancedCargoMovement的公司,其卡车类型通过演化形成了独特的七字母代码。历史学家试图寻找卡车类型之间的衍生路径,以确定质量最高的衍生计划。任务是编写程序计算最优质衍生计划的分数。输入是卡车类型的代码,输出是最大可能的质量分数。
摘要由CSDN通过智能技术生成

我是传送🚪
Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company’s history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan – i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.
Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output

For each test case, your program should output the text “The highest possible quality is 1/Q.”, where 1/Q is the quality of the best derivation plan.
Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0
Sample Output

The highest possible quality is 1/3.


大意:给出n个长度为7的字符串,找出每两个字符串之间不同字符的数量。求出最小和。


思路:用三个for循环将信息导入e的二维数组,赋值为不同字符的个数。然后使用prim模板即可

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int inf=99999999;
char a[2010][8];
int book[2010],e[2020][2020],dis[2020];
int main()
{
	int n,sum,i,j,ans,k,minn,f;
		while(~scanf("%d",&n)&&n)
	{
			memset(book,0,sizeof(book));
			sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%s",a[i]);
		}
		for(i=1;i<=n;i++)
		for(j=i+1;j<=n;j++)//细节,减小循环次数。 
		{
				if(i==j)
				continue;
				ans=0;
			for(k=0;k<7;k++)
			{
				if(a[i][k]!=a[j][k])
				ans++;
			}
			e[i][j]=e[j][i]=ans;
		}
		for(i=2;i<=n;i++)
		dis[i]=e[1][i];
		book[1]=0;
		for(i=1;i<=n-1;i++)
		{
			minn=inf;
			for(j=2;j<=n;j++)
			{
				if(book[j]==0&&dis[j]<minn)
				{
					minn=dis[j];
					f=j;
				}
			}
			sum+=minn;
			book[f]=1;
			for(j=1;j<=n;j++)
			{
				if(dis[j]>e[f][j]&&!book[j])
				dis[j]=e[f][j];
			}
		}
		printf("The highest possible quality is 1/%d.\n",sum);
	}
}

我是“大聪明”,祝你越来越聪明。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值