5561: Optimal Coin Change
时间限制: 1 Sec 内存限制: 128 MB提交: 91 解决: 67
[ 提交][ 状态][ 讨论版][命题人: admin]
题目描述
In a 10-dollar shop, everything is worthy 10 dollars or less. In order to serve customers more effectively at the cashier, change needs to be provided in the minimum number of coins.
In this problem, you are going to provide a given value of the change in different coins. Write a program to calculate the number of coins needed for each type of coin.
The input includes a value v, a size of the coinage set n, and a face value of each coin, f1, f2, ..., fn. The output is a list of numbers, namely, c1, ..., cn, indicating the number of coins needed for each type of coin. There may be many ways for the change. The value v is an integer satisfying 0 < v ≤ 2000, representing the change required
in cents. The face value of a coin is less than or equal to 10000. The output of your program should take the combination with the least number of coins needed.
For example, the Hong Kong coinage issued by the Hong Kong Monetary Authority consists of 10 cents, 20 cents, 50 cents, 1 dollar, 2 dollars, 5 dollars and 10 dollars would be represented in the input by n = 7, f1 = 10, f2 = 20, f3 = 50, f4 = 100, f5 = 200, f6 = 500, f7 = 1000.
In this problem, you are going to provide a given value of the change in different coins. Write a program to calculate the number of coins needed for each type of coin.
The input includes a value v, a size of the coinage set n, and a face value of each coin, f1, f2, ..., fn. The output is a list of numbers, namely, c1, ..., cn, indicating the number of coins needed for each type of coin. There may be many ways for the change. The value v is an integer satisfying 0 < v ≤ 2000, representing the change required
in cents. The face value of a coin is less than or equal to 10000. The output of your program should take the combination with the least number of coins needed.
For example, the Hong Kong coinage issued by the Hong Kong Monetary Authority consists of 10 cents, 20 cents, 50 cents, 1 dollar, 2 dollars, 5 dollars and 10 dollars would be represented in the input by n = 7, f1 = 10, f2 = 20, f3 = 50, f4 = 100, f5 = 200, f6 = 500, f7 = 1000.
输入
The test data may contain many test cases, please process it to the end of the file.
Each test case contains integers v, n, f1, ..., fn in a line. It is guaranteed that n ≤ 10 and 0 < f1 < f2 < ...< fn.
Each test case contains integers v, n, f1, ..., fn in a line. It is guaranteed that n ≤ 10 and 0 < f1 < f2 < ...< fn.
输出
The output be n numbers in a line, separated by space. If there is no possible change, your output should be a single −1. If there are more than one possible solutions, your program should output the one that uses more coins
of a lower face value.
样例输入
2000 7 10 20 50 100 200 500 1000
250 4 10 20 125 150
35 4 10 20 125 150
48 4 1 8 16 20
40 4 1 10 13 37
43 5 1 2 21 40 80
样例输出
0 0 0 0 0 0 2
0 0 2 0
-1
0 1 0 2
3 0 0 1
1 1 0 1 0
提示
来源
路径记录其实很简单,只需要记录住,这个状态 是从那个硬币过来的,递归一下就OK了
My ugly code
#include <bits/stdc++.h>
using namespace std;
const int maxn=2000+48;
int v,n;
int a[maxn];
int dp[maxn],minv[maxn],maxv[maxn];
int min_coin[maxn];
int vis[maxn];
void print_ans(int *d,int S){
while(S){
//printf("%d ",d[S]);
vis[ d[S] ]++;
S-=a[ d[S] ];
}
}
int main(){
while(~scanf("%d%d",&v,&n)){
for(int i=1;i<=n;i++) scanf("%d",a+i);
sort(a+1,a+1+n);
memset(dp,0x3f,sizeof(dp));
memset(vis,0,sizeof(vis));
for(int i=1;i<=v;i++){
minv[i]=0x3f3f3f3f;
maxv[i]=-0x3f3f3f3f;
}
dp[0]=0;
minv[0]=maxv[0]=0;
for(int i=1;i<=v;i++){
for(int j=1;j<=n;j++){
if(i >= a[j]){
if(minv[i] > minv[i-a[j] ]+1){
minv[i] = minv[i-a[j] ]+1;
min_coin[i]=j;
}
}
}
}
if(minv[v]==0x3f3f3f3f){
printf("-1\n");
continue ;
}
print_ans(min_coin,v);
printf("%d",vis[1]);
for(int i=2;i<=n;i++) printf(" %d",vis[i]);
printf("\n");
}
return 0;
}