华为网络设备常用命令大全

♥️作者:小刘在C站

♥️个人主页: 小刘主页 

♥️不能因为人生的道路坎坷,就使自己的身躯变得弯曲;不能因为生活的历程漫长,就使求索的 脚步迟缓。

♥️学习两年总结出的运维经验,以及思科模拟器全套网络实验教程。专栏:云计算技术

♥️感谢CSDN让你我相遇!

目录

华为设备模拟器

华为路由器与交换机

进入系统视图

查看所有配置信息

查看当前配置信息

配置主机名称

保存(重启后依旧保存配置)

退出当前视图

路由器接口配置ip

交换机配置ip地址(远程地址)

设备接口类型:

交换机或路由器配置远程登录

创建多个vlan

接口加入到vlan中

接口设置trunk链路(中继链路)

单臂路由

静态路由

默认路由

聚合链路(思科太网通道)

rip动态路由配置

OSPF动态路由

路由重分发

删除g0/0/1接口信息

关闭消息提示(用户视图下执行)


华为设备模拟器

可以使用eNSP模拟器,官网下载即可使用,但是需要三个前置应用,否则会报错,应用如下

  • 1-WinPcap
  • 2-Wireshark
  • 3-VirtualBox

不多介绍了,直接上干货


华为路由器与交换机

视图模式常见有两种分别是用户视图与系统视图(默认为用户视图)

进入系统视图
system-view
查看所有配置信息
disp   cur
查看当前配置信息
disp   this
配置主机名称
sysname   主机名
保存(重启后依旧保存配置)
save
退出当前视图
quit
路由器接口配置ip
int    g0/0/1                     //根据实际接口填写
ip     add   192.168.1.1 255.255.255.0
undo    shutdown  
交换机配置ip地址(远程地址)
int   vlan    1
ip    add    192.168.1.2   255.255.255.0
undo shutdown
设备接口类型:

        tenGigabitEthernet 万兆口

                GigabitEthernet 千兆口

                        Fastethernet百兆口

                                Ethernet十兆口

交换机或路由器配置远程登录
user1-interface    vty  0   4

authen        password        

set        authen         password      simple

user        privilege     level     3    (3-15为管理员级别)
创建多个vlan
valn    batch   2  to  10         //创建vlan2到10
接口加入到vlan中
int    g0/0/1
port    link-type   access
port    default     trunk
接口设置trunk链路(中继链路)
int g0/0/1
port link-type    trunk  
port   trunk    allow-pass   vlan   all
单臂路由
int    g/0/0/1.1
dot1q     termination    vid   10         //vlan10
ip   add   192.168.10.1   255.255.255.0  //网关
arp   broadcast  enable                 //开启ARP广播
静态路由
ip route-static  目标网段     子网掩码     下一跳地址
默认路由
ip   route-static  0.0.0.0 0.0.0.0   下一跳地址
聚合链路(思科太网通道)
(1)sw1(主):
lacp   priority   1000
int  Eth-Trunk   12
mode  lacp-static 
load-balance   dst-mac 
trunkport   GigabitEthernet 0/0/5
trunkport GigabitEthernet 0/0/6
port link-type   trunk 
port  trunk  allow-pass vlan   all 
quit

(3)SW2(副):
int  Eth-Trunk   12
mode  lacp-static 
trunkport   GigabitEthernet 0/0/5
trunkport GigabitEthernet 0/0/6
port link-type   trunk 
port  trunk  allow-pass vlan   all 
quit
rip动态路由配置
rip  
 undo summary
 version 2
 network 192.168.10.0        //宣告网段
 network 192.168.20.0       //宣告网段
OSPF动态路由
ospf 110           //进程号
 area   0                      //骨干区域
  network 192.168.2.0 0.0.0.255       //以下都为宣告网段,不同的是子网掩码变成反子网掩码
  network 192.168.3.0 0.0.0.255
  network 192.168.6.0 0.0.0.255
路由重分发
将rip重分发到ospf中
	ospf  110
	import-route    rip 1
将ospf重分发到rip中
	rip	
	import-route   ospf   110
rip默认路由重分发
  rip	
       default-route  originate 
       quit
ospf默认路由重分发
    ospf 110	
	default-route-advertise 
删除g0/0/1接口信息
clear configuration interface g0/0/1
关闭消息提示(用户视图下执行)
undo terminal monitor

没有提到什么视图使用的命令均为系统视图下使用。

  • 44
    点赞
  • 46
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 46
    评论
华为eNSP常用命令大全包括但不限于以下几个命令: 1. 进入特权模式: ``` <Huawei> system-view ``` 2. 修改设备名称: ``` [Huawei sysname <设备名称> ``` 3. 恢复设备名称为默认值: ``` [Huawei undo sysname ``` 4. 进入特定视图: ``` [Huawei <视图名称> ``` 5. 配置虚拟终端线路: ``` [Huawei user-interface vty 0 <线路号> ``` 请注意,这只是一部分华为eNSP常用命令的示例,实际上还有很多其他命令可以用于网络设备的配置和管理。您可以参考华为eNSP的官方文档或相关学习资料获取更全面的命令列表和详细说明。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [格雅Get 华为eNSP常用命令.docx](https://download.csdn.net/download/xxpr_ybgg/85632455)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* *3* [华为ensp常用操作命令 网络人凭经验含泪总结](https://blog.csdn.net/xiaobai729/article/details/123783178)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 46
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小刘在C站

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值