Algorithm Practice for 1579

Function Run Fun
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13742 Accepted: 7156

Description

We all love recursion! Don't we? Consider a three-parameter recursive function w(a, b, c): if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 1 if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: w(20, 20, 20) if a < b and b < c, then w(a, b, c) returns: w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) otherwise it returns: w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

Solution

 
 
import java.io.*;
import java.util.Hashtable;
public class Main{
 static  Hashtable<String,Integer> seenResult = new Hashtable<String,Integer>();
 
  public static Integer function(int a, int b, int c){
    int answerA, answerB, answerC,answerD;
    if(seenResult.containsKey(a + " " + b + " " + c)) {
      try{
       return seenResult.get((a + " " + b + " " + c));
       }catch(Exception e){
       }
     }
    if(a <= 0 || b <= 0 || c <= 0)
      return 1;
    else if(a > 20 || b > 20 || c > 20)
      return function(20,20,20);
    else if(a < b && b < c) {
      answerA = function(a,b,c - 1);
      seenResult.put((a + " " + b + " " + (c - 1)),new Integer(answerA));
      answerB = function(a,b - 1, c - 1);
      seenResult.put((a + " " + (b - 1) + " " + (c - 1)),new Integer(answerB));
      answerC = function(a,b - 1,c);
      seenResult.put((a + " " + (b - 1) + " " + c),new Integer(answerC));
      return (answerA + answerB - answerC);
    }
    else {
      answerA = function(a - 1,b,c);
      seenResult.put(((a - 1) + " " + b + " " + c),new Integer(answerA));
      answerB = function(a - 1,b - 1, c);
      seenResult.put(((a - 1) + " " + (b - 1) + " " + c),new Integer(answerB));
      answerC = function(a - 1,b,c - 1);
      seenResult.put(((a - 1) + " " + b + " " + (c - 1)),new Integer(answerC));
      answerD = function(a - 1,b - 1,c - 1);
      seenResult.put(((a - 1) + " " + (b - 1) + " " + (c - 1)),new Integer(answerD));
      return answerA + answerB + answerC - answerD;

   }
  }


  public static void main(String[] argv){
   BufferedReader inFromUser = new BufferedReader(new InputStreamReader(System.in));
   String strIn = null;
   String[] strABC = new String[3];
   int a = -1,b = -1,c = -1, result = 0;
   try{
     strIn = inFromUser.readLine();
   }catch(Exception e){
   
   }
   while(!strIn.startsWith("-1 -1 -1")) {
 	strABC = strIn.split(" ");
 	try{
     	a = Integer.parseInt(strABC[0]);
  	b = Integer.parseInt(strABC[1]);
 	c = Integer.parseInt(strABC[2]);
 	}catch(Exception e){
      	 System.err.println("Please input arguments: a b c");
  	 System.exit(0);
        }
        result = function(a,b,c);
      	try{
          seenResult.put(strIn,new Integer(result));
 	}catch(Exception e){
      	}
        System.out.println("w(" + a + ", " + b + ", " + c + ") = "  + result);
   	try{
     	  strIn = inFromUser.readLine();
   	}catch(Exception e){
   
   	}
  }
 }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值