Algorithm Practice for 1575

Easier Done Than Said?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3906 Accepted: 2167

Description

Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember. 

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules: 

It must contain at least one vowel. 

It cannot contain three consecutive vowels or three consecutive consonants. 

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'. 

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable. 

Input

The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output

For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input

a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end

Sample Output

<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.

Solution

package id1575;

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class EasierDoneThanSaid {
   BufferedReader in = null;
	public EasierDoneThanSaid(){
		in = new BufferedReader(new InputStreamReader(System.in));
	}
	
	public void start() throws IOException{
		String inStr = "";
		boolean flag1, flag2, flag3;
		inStr = in.readLine();
		while(!inStr.equals("end")){
			flag1 = containsVowel(inStr);
			flag2 = notConsecutiveChar(inStr);
			flag3 = notTwoConsecutiveLetter(inStr);
			if(flag1 && flag2 && flag3)
				System.out.println("<" + inStr + ">" + " is acceptable.");
			else
				System.out.println("<" +inStr + ">" + " is not acceptable.");

			inStr = in.readLine();
		}
	}
	private boolean notTwoConsecutiveLetter(String str){
		char[] charArr = str.toCharArray();
		for(int i = 0; i < charArr.length - 1; i++){
			if(charArr[i] == charArr[i + 1] && (charArr[i] != 'e' && charArr[i] != 'o'))
				return false;
		}
		return true;
	}
	
	private boolean containsVowel(String str){
		if(str.contains("a") || str.contains("e") || str.contains("i") || str.contains("o") || str.contains("u"))
			 return true;
		return false;
	}
	private boolean notConsecutiveChar(String str){
		char[] charArr = str.toCharArray();
		for(int i = 0; i < charArr.length - 2; i++){
			if(same(charArr[i],charArr[i+1],charArr[i+2]))
				return false;
		}
		return true;
	}
	
	private boolean same(char a, char b, char c){
		String vowel = "aeiou";
		String aStr = String.valueOf(a);
		String bStr = String.valueOf(b);
		String cStr = String.valueOf(c);
		if(vowel.contains(aStr) && vowel.contains(bStr) && vowel.contains(cStr))
			return true;
		if(!vowel.contains(aStr) && !vowel.contains(bStr) && !vowel.contains(cStr))
			return true;
		return false;
	}
	public static void main(String[] args) {
		try {
			new EasierDoneThanSaid().start();
		} catch (IOException e) {
			// TODO Auto-generated catch block
			e.printStackTrace();
		}

	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值