poj 3254 Corn Fields 状态压缩

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6321 Accepted: 3361

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  
第三个状态压缩 感觉智商遭到了侮辱 ∑(゚Д゚ノ)ノ
大意: 有一块由n*m个方格组成的农田,有些方块能种植谷物,有些方块不能种植谷物,现在fj有一些牛,这些牛吃谷物时各占一个方格,并且互不相邻,牛的数量不定并且牛只能在有农作物的方格里吃,给你田中每个方格的状态(0为可以种植 否则1),问有几种安排牛的方案。
解:牛的数量首先<=田中可以种植的方块的数量,详解如图:
下面是参考别的大神的代码 自己敲了个Orz(~ ̄▽ ̄)~(~ ̄▽ ̄)~ 一定要搞清楚 用十进制代表状态的思想
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#define N 12
using namespace std;
const  int maxx=1<<12;
const int mod=1e8;
int k;
int dp[15][maxx];
int sto[maxx];
int a[15],n,m;
bool judge(int x)
{
	if (x&x<<1) return false;
	return true;
}
void init()
{
    int v=1<<m;
     k=0;
    for (int i=0;i<v;i++)
    {
    	if (judge(i)) sto[++k]=i;
	}
}
bool base(int i,int l)
{
	if (i&a[l]) return false;
	return true;
}
int main()
{
	int ans,v;
   	while (~scanf("%d%d",&n,&m))
   	{
   		init();
   	   memset(dp,0,sizeof(dp));
   	   ans=0;
   	   for (int i=1;i<=n;i++)
   	   {
   	   	a[i]=0;
		for (int j=1;j<=m;j++)
		{
		    scanf("%d",&v);
			if (v==0)
			a[i]+=(1<<(m-j));	
		}
	    for (int i=1;i<=k;i++)//给第一行设个初值
	    {
	   	 if (base(sto[i],1))
		 dp[1][i]=1;
	    }
       }
       for (int i=2;i<=n;i++) //从第二行开始累加
       	    for (int j=1;j<=k;j++)
       	    {
       	       if (!base(sto[j],i)) continue;
			   for (int q=1;q<=k;q++)
			   {
			   	  if (!base(sto[q],i-1))continue;
			   	  if (sto[j]&sto[q])continue;
			   	  dp[i][j]=(dp[i][j]+dp[i-1][q])%mod;
			   }
		    }		   
        for (int i=1;i<=k;i++)
      	ans=(ans+dp[n][i])%mod; //计算第n行一共统计了多少种状态了
      	printf("%d\n",ans);
      }
      return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值