CSU~1336: Interesting Calculator(spfa)

1336: Interesting Calculator

            Time Limit: 2 Sec       Memory Limit: 128 Mb       Submitted: 755       Solved: 184    

Description

There is an interesting calculator. It has 3 rows of buttons.

 

Row 1: button 0, 1, 2, 3, ..., 9. Pressing each button appends that digit to the end of the display.

Row 2: button +0, +1, +2, +3, ..., +9. Pressing each button adds that digit to the display.

Row 3: button *0, *1, *2, *3, ..., *9. Pressing each button multiplies that digit to the display.

 

Note that it never displays leading zeros, so if the current display is 0, pressing 5 makes it 5 instead of 05. If the current display is 12, you can press button 3, +5, *2 to get 256. Similarly, to change the display from 0 to 1, you can press 1 or +1 (but not both!).

 

Each button has a positive cost, your task is to change the display from x to y with minimum cost. If there are multiple ways to do so, the number of presses should be minimized.

Input

There will be at most 30 test cases. The first line of each test case contains two integers x and y(0<=x<=y<=105). Each of the 3 lines contains 10 positive integers (not greater than 105), i.e. the costs of each button.

Output

For each test case, print the minimal cost and the number of presses.

Sample Input

12 2561 1 1 1 1 1 1 1 1 11 1 1 1 1 1 1 1 1 11 1 1 1 1 1 1 1 1 112 256100 100 100 1 100 100 100 100 100 100100 100 100 100 100 1 100 100 100 100100 100 10 100 100 100 100 100 100 100

Sample Output

Case 1: 2 2Case 2: 12 3

Hint

Source

湖南省第九届大学生计算机程序设计竞赛
刚一看果断就想要广搜,不过听说广搜会超时,看了大佬的代码,居然能用spfa写,感觉图论学X身上了
由于数据只有100000,所以可以开数组,用spfa直接跑一遍就行了,简单粗暴,却又令人反思
#include <iostream>
#include<string>
#include<string.h>
#include<stdio.h>
#include<stdlib.h>
#include<queue>
#include<math.h>
#include<algorithm>
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define maxn 100000+5
using namespace std;
int c[3][10],st,ed;
int dis[maxn],num[maxn];
int vis[maxn];
int Case=1;
void spfa()
{
    mem(dis,inf);
    mem(vis,0);
    queue<int>q;
    int u,v,t;
    q.push(st);
    vis[st]=1;
    num[st]=dis[st]=0;
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        vis[u]=0;
        for(int i=0;i<3;i++)
        {
            for(int j=0;j<10;j++)
            {
                if(i==0)
                v=u*10+j;
                else if(i==1)
                v=u+j;
                else
                v=u*j;
                if(v>ed)continue;
                if(dis[v]>dis[u]+c[i][j])
                {
                    dis[v]=dis[u]+c[i][j];
                    num[v]=num[u]+1;
                    if(!vis[v])
                    {
                        vis[v]=1;
                        q.push(v);
                    }
                }
            }
        }
    }
      printf("Case %d: %d %d\n",Case++,dis[ed],num[ed]);
}
int main()
{
    while(~scanf("%d%d",&st,&ed))
    {
        for(int i=0;i<3;i++)
        {
            for(int j=0;j<10;j++)
            {
                scanf("%d",&c[i][j]);
            }
        }
        spfa();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值