Ancient Go
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)Total Submission(s): 2258 Accepted Submission(s): 701
Problem Description
Yu Zhou likes to play
Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.
Here is the rules for ancient go they were playing:
⋅ The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
⋅ Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
⋅ The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board.
⋅ When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components.
One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.
Here is the rules for ancient go they were playing:
⋅ The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
⋅ Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
⋅ The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board.
⋅ When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components.
One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.
Input
The first line of the input gives the number of test cases,
T(1≤T≤100)
.
T
test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board.
′.′
represents an empty cell.
′x′
represents a cell with black chess which owned by Yu Zhou.
′o′
represents a cell with white chess which owned by Su Lu.
Output
For each test case, output one line containing
Case #x: y, where
x
is the test case number (starting from 1) and
y
is
Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu's components.
Can not kill in one move!!! otherwise.
Sample Input
2 .......xo ......... ......... ..x...... .xox....x .o.o...xo ..o...... .....xxxo ....xooo. ......ox. .......o. ...o..... ..o.o.... ...o..... ......... .......o. ...x..... ........o
Sample Output
Case #1: Can kill in one move!!! Case #2: Can not kill in one move!!!HintIn the first test case, Yu Zhou has 4 different ways to kill Su Lu's component. In the second test case, there is no way to kill Su Lu's component.
Source
一直在想着dfs搜后如何返回原状态,其实直接复制一下原图就好了,还有dfs搜o的时候,仔细想一下,其实不用每次把o都返回原状态
#include <iostream>
#include <iomanip>
#include<stdio.h>
#include<string.h>
#include<stack>
#include<stdlib.h>
#include<queue>
#include<map>
#include<math.h>
#include<algorithm>
#include<vector>
#define mem(a,b) memset(a,b,sizeof(a))
#define wtf printf("wtf\n");
using namespace std;
int go[4][2]={{1,0},{0,1},{-1,0},{0,-1}},flag,len;
char e[15][15];
char map1[15][15];
int book[15][15];
int inside(int x,int y)
{
if(x>=0&&x<=8&&y>=0&&y<=8)
return 1;
return 0;
}
void dfs(int x,int y)
{
for(int i=0;i<4;i++)
{
int tx=x+go[i][0];
int ty=y+go[i][1];
if(inside(tx,ty)&&e[tx][ty]=='.')
flag=1;
if(inside(tx,ty)&&e[tx][ty]=='o')
{
e[tx][ty]='*';
dfs(tx,ty);
}
}
}
int judge()
{
for(int i=0;i<9;i++)
{
for(int j=0;j<9;j++)
{
if(e[i][j]=='o')
{
e[i][j]='*';
flag=0;
dfs(i,j);
if(!flag)return 1;
}
}
}
return 0;
}
int solve()
{
for(int i=0;i<9;i++)
{
for(int j=0;j<9;j++)
{
if(map1[i][j]=='.')
{
map1[i][j]='x';
memcpy(e,map1,sizeof(map1));
if(judge())return 1;
map1[i][j]='.';
}
}
}
return 0;
}
int main()
{
int t,q=1;
scanf("%d",&t);
while(t--)
{
len=0;
for(int i=0;i<9;i++)
scanf("%s",map1[i]);
if(solve())
{
printf("Case #%d: Can kill in one move!!!\n",q++);
}
else
{
printf("Case #%d: Can not kill in one move!!!\n",q++);
}
}
return 0;
}