HDU1158-Employment Planning(dp)

Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5446    Accepted Submission(s): 2343


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project. 
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
  
  
3 4 5 6 10 9 11 0
 

Sample Output
  
  
199

对于每种状态可以分两种情况,雇佣和解雇,遍历雇佣和解雇的所有情况,刷新最小值即可

#include <iostream>
#include<cstdio>
#include<cstring>
#define mem(a,b) memset(a,b,sizeof(a))
#define N 15
#define ll long long
using namespace std;
int a[N],dp[N][1005];
int c1,c2,c3;
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        int maxx=0;
        mem(dp,0x3f3f3f3f);
        scanf("%d%d%d",&c1,&c2,&c3);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            maxx=max(maxx,a[i]);
        }
        for(int i=a[1];i<=maxx;i++)
            dp[1][i]=c1*i+c2*i;//第一个月的所有情况需要先计算出
        for(int i=1;i<=n;i++)
        {
            for(int j=a[i];j<=maxx;j++)
            {
                for(int k=0;k<=maxx;k++)
                {
                    if(k<=j)
                        dp[i][j]=min(dp[i][j],dp[i-1][k]+c1*(j-k)+c2*j);//雇佣(j-k)个人
                    else
                        dp[i][j]=min(dp[i][j],dp[i-1][k]+c3*(k-j)+c2*j);//解雇(k-j)个人
                }
            }
        }
        int ans=0x3f3f3f3f;
        for(int i=0;i<=maxx;i++)
            ans=min(ans,dp[n][i]);//在最后一个月中寻找最小值即为所求
            printf("%d\n",ans);
    }

}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值