Employment Planning

题目:
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project.
Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single ‘0’.
Output
The output contains one line. The minimal total cost of the project.
Sample Input
3
4 5 6
10 9 11
0
Sample Output
199

·
·
·

题目大意:第一行n,表示n个月份,要干n个月的活,
第二行三个数分别表示雇佣一个人需要的钱,,一个人工作的需要的工资,解雇一个人需要的钱。
第三行是每个月需要的最少的人数,不工作的人也要发工资
问 最少需要支付多少钱

题目思路:首先限制条件有两个一个是月份,一个是雇佣的人数,根据这个来取出最小值。dp[i][j]表示第i个月雇佣了j个人需要的最少的金钱,而这个月需要的钱,与上一个月雇佣的人数有关,所以这还需要一个循环来记录下人数,这从头到最大人数遍历一遍就可以了。

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int dp[15][10005];
int a[100];
int main()
{
    int t;
    while(cin>>t)
    {
        if(t==0)
            break;
            memset(a,0,sizeof(a));
            int maxx=0,cost,mn,jg;
            cin>>cost>>mn>>jg;
            for(int i=1;i<=t;i++)
            {
                cin>>a[i];
                if(maxx<a[i])
                    maxx=a[i];
            }
            memset(dp,0x3f3f3f,sizeof(dp));//因为是求最小的值就可以先把不需要的值,赋值为特别的数,这样不会影响最小值的求值
            for(int i=a[1];i<=maxx;i++)
            {
                dp[1][i]=i*mn+i*cost;
            }

            for(int i=2;i<=t;i++)
            {
                for(int j=a[i];j<=maxx;j++)
                {
                    for(int k=0;k<=maxx;k++)
                    {
                        if(k<=j)
                            dp[i][j]=min(dp[i][j],dp[i-1][k]+j*mn+(j-k)*cost);
                            else
                            {
                                dp[i][j]=min(dp[i][j],dp[i-1][k]+(k-j)*jg+j*mn);
                            }
                    }

                }
            }
            int minn=0x3f3f3f;
            for(int i=0;i<=maxx;i++)
            {
                minn=min(minn,dp[t][i]);
            }
            cout<<minn<<endl;

    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值