HDU4027-Can you answer these queries?(线段树+思路)

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 16133    Accepted Submission(s): 3771


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
  
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
  
  
Case #1: 19 7 6


直接更新肯定要超时,然后想用lazy怎么写,但始终没有找到好的思路,因为更新时只能由底向上更新,不能先更新上面的节点,那究竟怎么做

考虑到数据范围为2的63次方,也就是说这个数最多只能开7次平方,因为接下来如何再开方都是1了。所以更新到某个节点时,只要判断一下这点包含的区间(right-left+1),如果该点的值和区间大小相同,那么直接返回不用更新;

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define inf 0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define mem(a,b) memset(a,b,sizeof(a))
#define N 100010
using namespace std;
typedef __int64 ll;
ll f[N*4];
void build(ll l,ll r,ll rt)
{
    if(l==r)
    {
        scanf("%I64d",&f[rt]);
        return;
    }
    ll m=(l+r)>>1;
    build(lson);
    build(rson);
    f[rt]=f[rt<<1]+f[rt<<1|1];
}
void data(ll x,ll y,ll l,ll r,ll rt)
{
    if(l==r)
    {
        f[rt]=(ll)sqrt(1.0*f[rt]);
        return;
    }
    ll m=(l+r)>>1;
     if(y<=m)
         data(x,y,lson);
    else if(x>m)
         data(x,y,rson);
    else
    {
         data(x,m,lson);
         data(m+1,y,rson);
    }
    f[rt]=f[rt<<1]+f[rt<<1|1];
}
void update(ll x,ll y,ll l,ll r,ll rt)
{
    if(l==x&&r==y)
    {
        if(f[rt]==r-l+1)return;
        data(x,y,l,r,rt);
return;
    }
    ll m=(l+r)>>1;
    if(y<=m)
         update(x,y,lson);
    else if(x>m)
         update(x,y,rson);
    else
    {
         update(x,m,lson);
         update(m+1,y,rson);
    }
    f[rt]=f[rt<<1]+f[rt<<1|1];
}
ll query(ll x,ll y,ll l,ll r,ll rt)
{
    if(x==l&&y==r)
    {
        return f[rt];
    }
    ll m=(l+r)>>1;
    if(y<=m)
        return query(x,y,lson);
    else if(x>m)
        return query(x,y,rson);
    else
    {
        return query(x,m,lson)+query(m+1,y,rson);
    }
}
int main()
{
    ll n,q=1;
    while(~scanf("%I64d",&n))
    {
        build(1,n,1);
        ll m,x,y,op;
        scanf("%I64d",&m);
        printf("Case #%I64d:\n",q++);
        for(ll i=0; i<m; i++)
        {
            scanf("%I64d%I64d%I64d",&op,&x,&y);
            if(x>y)
                swap(x,y);
            if(!op)
            {
                update(x,y,1,n,1);
            }
            else
            {
                printf("%I64d\n",query(x,y,1,n,1));
            }
        }
        printf("\n");
    }
    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值