POJ 3468 A Simple Problem with Integers(线段树区间更新模板题)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 108110 Accepted: 33683
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15
线段树区间更新的模板题,存一下模板,lazy表示延迟更新,如果这一点更新不到,那么他的子节点就不用再更新了;

#include <iostream>
#include <iomanip>
#include<stdio.h>
#include<string.h>
#include<stack>
#include<stdlib.h>
#include<queue>
#include<map>
#include<math.h>
#include<algorithm>
#include<vector>
#define maxn 100010
#define ll long long
using namespace std;
struct node
{
    ll v,L,R;
    ll mid()
    {
        return (L+R)>>1;
    }
}t[maxn<<2];
ll lazy[maxn<<2];
void build(ll l,ll r,ll rt)
{
    t[rt].L=l;
    t[rt].R=r;
    if(l==r)
    {
        scanf("%lld",&t[rt].v);
        return;
    }
    ll m=t[rt].mid();
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
    t[rt].v=t[rt<<1].v+t[rt<<1|1].v;
}
void pushdown(ll rt,ll m)
{
     if(lazy[rt])
     {
         lazy[rt<<1]+=lazy[rt];
         lazy[rt<<1|1]+=lazy[rt];
         t[rt<<1].v+=lazy[rt]*(m-(m>>1));
         t[rt<<1|1].v+=lazy[rt]*(m>>1);
         lazy[rt]=0;
     }
}
void update(ll num,ll l,ll r,ll rt)
{
    if(t[rt].L==l&&t[rt].R==r)
    {
        lazy[rt]+=num;
        t[rt].v+=num*(t[rt].R-t[rt].L+1);
        return;
    }
    pushdown(rt,t[rt].R-t[rt].L+1);
    ll m=t[rt].mid();
    if(r<=m)
        update(num,l,r,rt<<1);
    else if(l>m)
        update(num,l,r,rt<<1|1);
    else
    {
        update(num,l,m,rt<<1);
        update(num,m+1,r,rt<<1|1);
    }

    t[rt].v=t[rt<<1].v+t[rt<<1|1].v;
}
ll query(ll l,ll r,ll rt)
{
    if(t[rt].L==l&&t[rt].R==r)
    return t[rt].v;
    pushdown(rt,t[rt].R-t[rt].L+1);
    ll m=t[rt].mid();
    if(r<=m) return query(l,r,rt<<1);
    else if(l>m)  return query(l,r,rt<<1|1);
    else
        return query(l,m,rt<<1)+query(m+1,r,rt<<1|1);
}
int main()
{

    ll n,m,x,y,z;
    scanf("%lld%lld",&n,&m);
    build(1,n,1);
    char op[5];
    for(ll i=1;i<=m;i++)
    {
        scanf("%s",op);
        if(op[0]=='C')
        {
            scanf("%lld%lld%lld",&x,&y,&z);
            update(z,x,y,1);
        }
        else
        {
            scanf("%lld%lld",&x,&y);
            printf("%lld\n",query(x,y,1));
        }
    }
    return 0;

}




  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值