ZOJ1610 Count the Colors(线段树+思路)

Count the Colors

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1

经典的线段树染色问题,由于一个位置只能有一种颜色,所以每次更新区间的时候,直接可以把t当作lazy数组用

查询类似于建树,这样可以查询出每个点的颜色

坑点:每次更新到给出范围的最大值,由于每次染色的都是一个区间,如果一个区间的右端点和另一个区间的左端点重合时,染色会重复,因此每次在左端点+1

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<map>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
typedef long long ll;
const int inf=0x3f3f3f3f;
const int maxn=8010;
const int N=8000;
int color[maxn<<2],t[maxn<<2];
int book[maxn<<2];
void pushdown(int rt)
{
    t[rt<<1]=t[rt<<1|1]=t[rt];
    t[rt]=-1;
}
void update(int x,int y,int l,int r,int rt,int val)
{
    if(l>=x&&r<=y)
    {
        t[rt]=val;
        return;
    }
    if(t[rt]==val)return;
    if(t[rt]!=-1)pushdown(rt);
    int m=(l+r)>>1;
    if(x<=m)
        update(x,y,l,m,rt<<1,val);
    if(y>m)
        update(x,y,m+1,r,rt<<1|1,val);
}
void query(int l,int r,int rt)
{
    if(t[rt]!=-1)
    {
        for(int i=l;i<=r;i++)
            color[i]=t[rt];
        return;
    }
    if(l==r)return;
    int m=(l+r)>>1;
    query(l,m,rt<<1);
    query(m+1,r,rt<<1|1);
}
int main()
{
     int n,x,y,z;
    while(~scanf("%d",&n))
    {
        mem(t,-1);
        mem(color,-1);
        mem(book,0);
        int ans=0,maxx=-1;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            update(x+1,y,1,N,1,z);
            maxx=max(maxx,z);
        }
        query(1,N,1);
        int temp=-1;
         for(int i=1;i<=N;i++)
         {
             if(color[i]!=temp)
             {
                 if(color[i]!=-1)
                    ++book[color[i]];
                 temp=color[i];
             }
         }
         for(int i=0;i<=maxx;i++)
         {
             if(book[i])
                printf("%d %d\n",i,book[i]);
         }
         printf("\n");
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值