HDU6152 Friend-Graph(拉姆齐定理)

Friend-Graph

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1378    Accepted Submission(s): 699


Problem Description
It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.( n3000 )

Then there are n-1 rows. The  i th row should contain n-i numbers, in which number  aij  represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.
 

Output
Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.
 

Sample Input
  
  
1 4 1 1 0 0 0 1
 

Sample Output
  
  
Great Team!

拉姆齐定理:6个人中至少存在3个或3个以上的人互不认识

题意,问给出关系中,是否存在3个或3个以上的人相互认识

所以>=6直接输出bad,<6暴力即可

#include<bits/stdc++.h>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxn=2e5+10;
int e[10][10],n;

int main()
{
    int t,x;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        mem(e,0);
        for(int i=1;i<n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                scanf("%d",&x);
                if(x&&n<6)e[j][i]=e[i][j]=1;
            }
        }
        if(n>=6)
        {
            printf("Bad Team!\n");
            continue;
        }
        bool flag=0;
       for(int i=1;i<=n;i++)
       {
           for(int j=i+1;j<=n;j++)
           {
               for(int k=j+1;k<=n;k++)
               {
                   if(e[i][j]&&e[i][k]&&e[j][k])
                   {
                       flag=true;
                       break;
                   }
               }
           }
       }
        if(!flag)
            printf("Great Team!\n");
        else
            printf("Bad Team!\n");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值