hdu1520 Anniversary party(树形dp)

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13619    Accepted Submission(s): 5384


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

Output
Output should contain the maximal sum of guests' ratings.
 

Sample Input
      
      
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
      
      
5
 

树形dp入门题

题意:有n个人,每个人有一个欢乐度,下面给出许多父子关系,现在要举行宴会,当父与子同时到场时他们会不开心,求最大的欢乐度

对于每个人,有到与不到两种状态,我们可以用0和1来标记

可得状态方程 

dp[fa][1]+=dp[son][0]  //父亲来,则该点的权等于所有儿子不来的最大权和

dp[fa][0]+=max(dp[son][1],dp[son][0])  //父亲不来,则该点的权等于max(所有儿子来或不来)权和

首先用并查集找了一下根

然后通过递归,先求出叶节点的值,由叶向根回推即可

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<vector>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int N=6010;
const int M=400010;
int f[N],dp[N][2],a[N];
vector<int>e[N];
int getf(int x)
{
    return x==f[x]?x:f[x]=getf(f[x]);
}
void mix(int x,int y)
{
    int tx=getf(x);
    int ty=getf(y);
    if(tx!=ty)
    {
        f[tx]=ty;
    }
}
void dfs(int x)
{
    dp[x][1]+=a[x];
    for(int i=0; i<e[x].size(); i++)
    {
        int v=e[x][i];
        dfs(v);
        dp[x][0]+=max(dp[v][0],dp[v][1]);
        dp[x][1]+=dp[v][0];
    }
}
int main()
{
    int n,x,y,root;;
    while(~scanf("%d",&n))
    {
        mem(dp,0);
        for(int i=1; i<=n; i++)scanf("%d",&a[i]);
        for(int i=1; i<=n; i++)
        {
            e[i].clear(),f[i]=i;
        }
        while(scanf("%d%d",&x,&y)&&x+y)
        {
            e[y].push_back(x);
            mix(x,y);
        }
        
        for(int i=1; i<=n; i++)
        {
            if(i==getf(i))
            {
                root=i;
                break;
            }
        }
        dfs(root);
        printf("%d\n",max(dp[root][0],dp[root][1]));
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值