HDOJ_1049Climbing Worm(爬)

Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
 

Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
 

Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
 

Sample Input
  
  
10 2 1 20 3 1 0 0 0
 

Sample Output
  
  
17 19
 

问题描述:

一英寸的蠕虫在一英寸深的井的底部。它有足够的能量每分钟爬上你的脚,但是在爬之前必须休息一分钟。在余下的时间里,它下降到D英寸。攀登和休息的过程然后重复。虫子从井里爬出来还有多久?我们总是把一分钟的一分钟算为一分钟,如果虫子在爬完的时候到达了井顶,我们就假设虫子把它弄出来了。

输入:

将有多个问题实例。每一行包含3个正整数n,u和d。这些值给出上面段落中提到的值。此外,可以假设d<u和n<100。n=0的值表示输出结束。

输出:

每一个输入实例都应该在一行上生成一个整数,表示蠕虫从井里爬出来所需的时间。

输入:
  
  
10 2 1 20 3 1 0 0 0

输出:

 
 
17 19



#include<stdio.h>
int main()
{
    int n,u,d,time,wz;
    while(scanf("%d%d%d",&n,&u,&d)&&(n!=0&&u!=0&&d!=0))
    {
        time=0,wz=0;
        while(wz<n)
        {
            time++;
            wz+=u;
            if(wz<n){
                wz-=d;
                    time++;
            }
        }
        printf("%d\n",time);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值