题目 :
You are to find all the two-word compound words in a dictionary. A two-word compound word is a
word in the dictionary that is the concatenation of exactly two other words in the dictionary.
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will
be no more than 120,000 words.
Output
Your output should contain all the compound words, one per line, in alphabetical order.
Sample Input
a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra
Sample Output
alien
newborn
思路: set的应用。
a = b.substr(id,lenth);
a和b都是string类型
substr用于取子串。
#include <bits/stdc++.h>
using namespace std;
set<string> data;
int main()
{
char s[100];
while(~scanf("%s",s))
data.insert(s);
set<string>::iterator it = data.begin();
for(; it != data.end(); it++)
{
string temp = *it;
int slen = temp.size();
string one,two;
for(int i = 1; i < slen; i++)
{
one = temp.substr(i);
two = temp.substr(0 ,i);
//cout<<two<<" "<<one<<endl;
if(data.count(one) && data.count(two))
{
cout<<temp<<endl;
break;
}
}
}
return 0;
}