01-复杂度2 Maximum Subsequence Sum (25分)

Given a sequence of KK integers { N_1N1N_2N2, ..., N_KNK }. A continuous subsequence is defined to be { N_iNiN_{i+1}Ni+1, ..., N_jNj } where 1 \le i \le j \le K1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer KK (\le 1000010000). The second line contains KK numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices ii and jj (as shown by the sample case). If all the KK numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1  4


题目其实就是最大子列和,跟之前那题一样,用了简单的方法,复杂度为n就可以。但是要输出起始和最终的数字,细节处理上花了点时间,代码也不太好看,但是好歹是过了,有时间来优化一下。
#include<iostream>
using namespace std;
int a[10001];
int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>a[i];
	}
	int cnt=0,mm=-1;
	int l=a[0],r=a[n-1],ll=a[0];
	for(int i=0;i<n;i++)
	{
		cnt+=a[i];
		if(cnt>mm)
		{
			mm=cnt;
			r=a[i];
			l=ll;
		}
		if(cnt<0)
		{
			cnt=0;
			if(i>=n-1)
			{
				if(mm<0)
				{
				 l=a[0];
				 r=a[n-1];
				 mm=0;
				}
			}
			else
			{
				ll=a[i+1];
			}
		}
	}
	cout<<mm<<" "<<l<<" "<<r<<endl;
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

没想好叫什么名字

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值