HDU-1524-A Chess Game && POJ-2425 【sg】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1524



A Chess Game



Problem Description
Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again. 

Do you want to challenge me? Just write your program to show your qualification!
 

Input
Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.
 

Output
There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.
 

Sample Input
  
  
4 2 1 2 0 1 3 0 1 0 2 0 2 0 4 1 1 1 2 0 0 2 0 1 2 1 1 3 0 1 3 0
 

Sample Output
  
  
WIN WIN WIN LOSE WIN


题目分析:

有n个位置,存在拓扑关系,也就是说:在一个有向无环图上有n个顶点,有两个人,每次沿着有向图的边只能将任意一颗棋子移动一步,如果到某一步玩家不能移动时,那么这个人就输了.把所有顶点的SG值都计算出来,然后对每个棋子的SG值进行异或运算,如果异或值为0就是先手必败态。

关于输入:输入一个n,接下来构建有向图,n行表示0-n-1为起点的有向边,每行的第一个数表示与起点相连的终点个数,之后是各个终点。
接下来就要在有向图的顶点上放棋子。输入m,表示有m个棋子,之后m个数是棋子所在的顶点编号,m为0时结束。



#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n;
int sg[1005];
int mp[1005][1005];
int get_sg(int xx)
{
	if(sg[xx]!=-1)
	return sg[xx];
	bool visit[1005];
	memset(visit,0,sizeof(visit));
	int i,j;
	for(i=0;i<n;i++)
	{
		if(mp[xx][i]==1)
		{
			get_sg(i);
			visit[sg[i]]=1;
		}
	}
	for(i=0;;i++)
	{
		if(!visit[i])
		{
			sg[xx]=i;
			break;
		}
	}
	return sg[xx];
}
int main()
{
	int x,xi,m,k;
    int i,j;
	while(~scanf("%d",&n))
	{
	    memset(sg,-1,sizeof(sg));
	    memset(mp,0,sizeof(mp));
		for(i=0;i<n;i++)
		{
			scanf("%d",&x);
			if(x==0)
			sg[i]=0;
			while(x--)
			{
				scanf("%d",&xi);
				mp[i][xi]=1;
			}
		}
		while(~scanf("%d",&m))
		{
			if(m==0)
			break;
			int ans=0;
			while(m--)
			{
				scanf("%d",&k);
				ans^=get_sg(k);
			}
			if(ans)
			cout<<"WIN"<<endl;
			else
			cout<<"LOSE"<<endl;
		}
	}	
	return 0;
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值