zufeoj_凑数字

题目链接:http://acm.ocrosoft.com/problem.php?cid=1172&pid=18


题目描述

有n个数字,a[1],a[2],a[3]......a[n],以及一个数字m。

问n个数字中取出一些数字,这些数字的和能否等于m。

输入

多组测试数据,读入到文件尾结束。

第一行输入n,m。(1<=n<=20, 1<=m<=100)

第二行输入n个数字a[1],a[2],a[3]......a[n]。(1<=a[i]<=100)

输出

如果可以,输出YES,否则输出NO。 

样例输入

5 5
1 1 1 1 1
5 5
2 2 2 2 2

样例输出

YES
NO


#include<bits/stdc++.h>
using namespace std;
int a[111];
int n,m;
bool flag=1;
void dfs(int s,int x){
    if(x>=n){
        if(s==m){
            flag=0;
            return;
        }else{
            return;
        }
    }
    dfs(s+a[x],x+1);
    dfs(s,x+1);
}
int main(){
 
    while(cin>>n>>m){
        flag=1;
        for(int i=0;i<n;i++){
            cin>>a[i];
        }
        dfs(0,0);
        if(flag==0){
            cout<<"YES"<<endl;
        }else{
            cout<<"NO"<<endl;
        }   
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值