PAT (Advanced Level) Practice — 1088 Rational Arithmetic (20 分)

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805378443755520

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

:题意  输入两个分数,输出其四则运算的结果,如果除数为0,那么相除的结果为inf       PAT(A)-1081

参考《算法笔记》分数的四则运算部分

注意:

  • 输入的分数不一定是最简的,输出格式要求为最简格式
  • 如果分数为负数的话用括号括起来
  • 输出的结果为假分数
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
typedef long long ll;
struct Fraction{
	ll up;//分子 
	ll down;//分母 
};
ll gcd(ll x,ll y){
	if(!y){
		return x;		
	}else{
		return gcd(y,x%y);
	}
} 
Fraction reduction(Fraction res){
	if(res.down<0){
		res.up=-res.up;
		res.down=-res.down;
	}
	if(res.up==0){ 
		res.down=1;
	}else{
		ll t=gcd(abs(res.up),abs(res.down));
		res.up/=t;
		res.down/=t; 
	} 
	return res;
}
Fraction add(Fraction f1,Fraction f2){
	Fraction res;
	res.up=f1.up*f2.down+f2.up*f1.down;
	res.down=f1.down*f2.down;
	return reduction(res);
}
Fraction sub(Fraction f1,Fraction f2){
	Fraction res;
	res.up=f1.up*f2.down-f2.up*f1.down;
	res.down=f1.down*f2.down;
	return reduction(res);
}
Fraction mul(Fraction f1,Fraction f2){
	Fraction res;
	res.up=f1.up*f2.up;
	res.down=f1.down*f2.down;
	return reduction(res);
}
Fraction div(Fraction f1,Fraction f2){
	Fraction res;
	res.up=f1.up*f2.down;
	res.down=f1.down*f2.up;
	return reduction(res);
}
void print(Fraction res){
	res=reduction(res);
	if(res.up<0){
		printf("(");
	}
	if(res.down==1){
		printf("%lld",res.up);
	}else if(abs(res.up)>res.down){
		ll t=abs(res.up);
		printf("%lld %lld/%lld",res.up/res.down,t%res.down,res.down);
	}else{
		printf("%lld/%lld",res.up,res.down);
	}
	if(res.up<0){
		printf(")");
	}
}
int main(){
	Fraction f1,f2;
	scanf("%lld/%lld %lld/%lld",&f1.up,&f1.down,&f2.up,&f2.down);
	f1=reduction(f1);
	f2=reduction(f2);
	char str[4][5]={"+","-","*","/"};
	for(int i=0;i<4;i++){
		print(f1);
		printf(" %s ",str[i]);
		print(f2);
		printf(" = ");
		switch(i){
			case 0:
				print(add(f1,f2)); 
				break;
			case 1:
				print(sub(f1,f2));
				break;
			case 2:
				print(mul(f1,f2));
				break;
			default: 
				if(f2.up==0){
					printf("Inf");
				}else{
					print(div(f1,f2));
				}		
		}
		printf("\n");
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值