PAT (Advanced Level) Practice — 1093 Count PAT's (25 分)

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805373582557184

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

:题意

  • PAT的数量可以巧妙地认为是每个A的左边的P的数量乘以右边T的数量。 
  • 用数组L记录左边P的数量、R数组记录右边T的数量
  • 注意题目中,output the result moded by 1000000007 因为测试样例结果过大,需要将结果取模,但是如果仅仅在最后取模,因为在中间过程已经越界,结果还是不对,所以在遍历每个A的时候就取模,进而防止越界。
#include<iostream>
#include<cstring>
using namespace std;
const int mod = 1000000007;
const int maxx=1e5+11;
char s[maxx];
int l[maxx];
int r[maxx];	
int main(){
	int n;
	cin>>s;
	int len=strlen(s);
	int cnt=0;
	for(int i=0;i<len;i++){
		if(s[i]=='P'){
			cnt++;
		}else if(s[i]=='A'){
			l[i]=cnt;
		}
	}
	cnt=0;
	for(int i=len-1;i>=0;i--){
		if(s[i]=='T'){
			cnt++;
		}else if(s[i]=='A'){
			r[i]=cnt;
		}
	}
	int ans=0;
	for(int i=0;i<len;i++){
		if(l[i]!=0){
			ans=(ans+(l[i]*r[i])%mod)%mod;
		}
	}
	printf("%d\n",ans);
	
	return 0;
}

也可以直接累加

#include<iostream>
#include<cstring>
using namespace std;
const int mod = 1000000007;
const int maxx=1e5+11;
char s[maxx];	
int main(){
	cin>>s;
	int len=strlen(s);
	int p=0,pa=0,pat=0;
	for(int i=0;i<len;i++){
		if(s[i]=='P'){
			p++;
		}else if(s[i]=='A'){
			pa=(pa+p)%mod; 
		}else{
			pat=(pat+pa)%mod;
		}
	}
	printf("%d\n",pat%mod);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值