PAT (Advanced Level) Practice — 1093 Count PAT's (25 分)

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805373582557184

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

:题意

  • PAT的数量可以巧妙地认为是每个A的左边的P的数量乘以右边T的数量。 
  • 用数组L记录左边P的数量、R数组记录右边T的数量
  • 注意题目中,output the result moded by 1000000007 因为测试样例结果过大,需要将结果取模,但是如果仅仅在最后取模,因为在中间过程已经越界,结果还是不对,所以在遍历每个A的时候就取模,进而防止越界。
#include<iostream>
#include<cstring>
using namespace std;
const int mod = 1000000007;
const int maxx=1e5+11;
char s[maxx];
int l[maxx];
int r[maxx];	
int main(){
	int n;
	cin>>s;
	int len=strlen(s);
	int cnt=0;
	for(int i=0;i<len;i++){
		if(s[i]=='P'){
			cnt++;
		}else if(s[i]=='A'){
			l[i]=cnt;
		}
	}
	cnt=0;
	for(int i=len-1;i>=0;i--){
		if(s[i]=='T'){
			cnt++;
		}else if(s[i]=='A'){
			r[i]=cnt;
		}
	}
	int ans=0;
	for(int i=0;i<len;i++){
		if(l[i]!=0){
			ans=(ans+(l[i]*r[i])%mod)%mod;
		}
	}
	printf("%d\n",ans);
	
	return 0;
}

也可以直接累加

#include<iostream>
#include<cstring>
using namespace std;
const int mod = 1000000007;
const int maxx=1e5+11;
char s[maxx];	
int main(){
	cin>>s;
	int len=strlen(s);
	int p=0,pa=0,pat=0;
	for(int i=0;i<len;i++){
		if(s[i]=='P'){
			p++;
		}else if(s[i]=='A'){
			pa=(pa+p)%mod; 
		}else{
			pat=(pat+pa)%mod;
		}
	}
	printf("%d\n",pat%mod);
	return 0;
}

 

### PAT 基本级别练习的相关资料 PAT(Programming Ability Test)是一项针对编程能力的标准化考试,其基本级别主要考察考生的基础编程技能和逻辑思维能力。以下是关于 PAT 基本级别的练习题目及相关解决方案的内容。 #### 题目PAT 基本级别的题目通常为以下几个类别: 1. **字符串处理**:涉及字符串的操作,如反转、查找子串等。 2. **数组操作**:包括数组排序、去重、统计等问题。 3. **简单算法实现**:如计算阶乘、判断素数等基础算法。 4. **输入输出格式化**:要求按照特定格式读取数据并输出结果。 以下是一些典型的 PAT 基本级别练习题及其解决思路: --- #### 示例题目 1: 字符串反转 **描述**: 输入一个字符串,将其逆序输出。 **解法**: 可以通过 Python 中的切片功能轻松实现字符串反转。 ```python def reverse_string(s): return s[::-1] # 测试用例 input_str = input() print(reverse_string(input_str)) ``` 此代码利用了 Python 切片语法 `s[start:end:step]`,其中步长为 `-1` 表示反向遍历字符串[^4]。 --- #### 示例题目 2: 数组求和 **描述**: 给定一组整数,求数组中所有元素的总和。 **解法**: 通过循环累加或者内置函数 `sum()` 实现数组求和。 ```python def array_sum(arr): return sum(arr) # 测试用例 numbers = list(map(int, input().split())) print(array_sum(numbers)) ``` 上述代码中,`map()` 函数用于将输入转换为整型列表,而 `sum()` 是 Python 的内置函数,能够高效完成求和任务[^5]。 --- #### 示例题目 3: 计算阶乘 **描述**: 输入一个正整数 \( n \),输出它的阶乘 \( n! \)。 **解法**: 使用递归或迭代方式均可实现阶乘计算。 ```python def factorial(n): if n == 0 or n == 1: return 1 result = 1 for i in range(2, n + 1): result *= i return result # 测试用例 n = int(input()) print(factorial(n)) ``` 该程序采用了迭代方法避免栈溢出的风险,在实际应用中更为稳健[^6]。 --- #### 示例题目 4: 判断素数 **描述**: 输入一个正整数 \( m \),判断它是否为素数。 **解法**: 素数是指仅能被 1 和自身整除的大于 1 的自然数。可通过试除法验证。 ```python import math def is_prime(m): if m <= 1: return False sqrt_m = int(math.sqrt(m)) + 1 for i in range(2, sqrt_m): if m % i == 0: return False return True # 测试用例 m = int(input()) if is_prime(m): print("Yes") else: print("No") ``` 在此代码片段中,引入了平方根优化技术以减少不必要的运算次数[^7]。 --- ### 总结 以上展示了几个常见的 PAT 基础级问题以及对应的解决方案。这些例子涵盖了字符串操作、数组处理、数学计算等多个方面,有助于初学者熟悉 PAT 考试的形式与难度。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值