华为DHCP配置

  • 为了方便 吧二层交换机都以24口连接核心交换机的网口1,2口

    先配置核心交换机 coresw  

    开启DHCP 服务

    <coreSW>system-view

    [coreSW]dhcp enable

  • 增加地址池

    [coreSw]ip pool 10    新增地址池名称为 10

    [coreSw-ip-pool-10]network 192.168.10.0 mask 24    网络地址段24代替

    255.255.255.0

    [coreSw-ip-pool-10]gateway-list 192.168.10.254    网关地址

    [coreSw-ip-pool-10]dns-list 8.8.8.8   dns 地址

    [coreSw-ip-pool-10]lease day 1 hour 1   租用时间   默认不填为1天

    [coreSw]ip pool 10    新增地址池名称为 10

    [coreSw-ip-pool-20]network 192.168.20.0 mask 24    网络地址段24代替

    255.255.255.0

    [coreSw-ip-pool-20]gateway-list 192.168.20.254    网关地址

    [coreSw-ip-pool-20]dns-list 114.114.114.114   dns 地址

    [coreSw-ip-pool-20]lease day 1 hour 1   租用时间   默认不填为1天

  • 开启端口trunk  目前只试验1,2 端口 所以只展示 1,2口的代码,如需多个端口请自行增加

    [coreSw]interface gi0/0/1

    [coreSw-GigabitEthernet0/0/1]port link-type trunk

    [coreSw-GigabitEthernet0/0/1]port trunk allow-pass vlan all

    [coreSw]interface gi0/0/2

    [coreSw-GigabitEthernet0/0/2]port link-type trunk

    [coreSw-GigabitEthernet0/0/2]port trunk allow-pass vlan all

  • 分配vlanif 端口配置

    先划分vlan  10 和 20

    [coreSw-vlan10]vlan 10

    [coreSw-vlan20]vlan 20

    [coreSw-vlan20]interface vlan 10 进入 vlanif  10

    [coreSw-Vlanif10]ip address  192.168.10.1 24

    [coreSw-Vlanif10]dhcp select global

    [coreSw-vlan10]interface vlan 20

    [coreSw-Vlanif20]ip address  192.168.20.1 24

    [coreSw-Vlanif20]dhcp select global

    核心交换机配置完成dis cur  配置结果

    #

    sysname coreSw

    #

    vlan batch 10 20

    dhcp enable

    #

    diffserv domain default

    #

    drop-profile default

    #

    ip pool 10

    gateway-list 192.168.10.1 192.168.10.254

    network 192.168.10.0 mask 255.255.255.0

    lease day 1 hour 1 minute 0

    dns-list 8.8.8.8

    #

    ip pool 20

    #

    interface Vlanif1

    #

    interface Vlanif10

    ip address 192.168.10.1 255.255.255.0

    dhcp select global

    #

    interface MEth0/0/1

    #

    interface GigabitEthernet0/0/1

    port link-type trunk

    port trunk allow-pass vlan 2 to 4094

    #

    interface GigabitEthernet0/0/2

    port link-type trunk

    port trunk allow-pass vlan 2 to 4094

  • 配置二层交换机

    <Huawei>system-view 进入视图模式

    [Huawei]vlan batch 10 20  划分 vlan  10  20 

    [Huawei]interf g0/0/1

    [Huawei-GigabitEthernet0/0/1]port link-type access

    [Huawei-GigabitEthernet0/0/1]port default vlan 10

    [Huawei]interf g0/0/2

    [Huawei-GigabitEthernet0/0/2]port link-type access

    [Huawei-GigabitEthernet0/0/2]port default vlan 10

    开通24口的 trunk

    [Huawei]inter g0/0/24

    [Huawei-GigabitEthernet0/0/24]port link-type trunk

    [Huawei-GigabitEthernet0/0/24]port trunk allow-pass vlan all

    quit

  • 打开电脑,设置为DHCP 自动获取 需要等待20秒左右,ipconfig  自动获取ip  不同vlan 获取不同的 ip地址段(vlan 10  获取  192.168.10.x 段ip 地址)

根据具体问题类型,进行步骤拆解/原因原理分析/内容拓展等。
具体步骤如下:/导致这种情况的原因主要是……

©️2020 CSDN 皮肤主题: 大白 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值