Description
将字符串t插入到字符串s中,在位置pos后插入。不得使用字符串操作函数,输出组合成的字符串。
将字符串t插入到字符串s中,在位置pos后插入。不得使用字符串操作函数,输出组合成的字符串。
Input
输入两个字符串(t和s)和要插入的位置(pos)
输入两个字符串(t和s)和要插入的位置(pos)
Output
输出组合后的字符串
输出组合后的字符串
Sample Input
qwe
jij
3
Sample Output
jijqwe
HINT
qwe
jij
3
Sample Output
jijqwe
HINT
#include<stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
char a[80],b[40];
int i,j,n;
scanf("%s",a);
scanf("%s",b);
scanf("%d",&n);
for(i=0;i<strlen(b);i++)
{
printf("%c",b[i]);
if(i+1==n)
{
for(j=0;j<strlen(a);j++)
printf("%c",a[j]);
}
}
return 0;
}