PAT (Advanced Level) Practice 1001 A+B Format (20 分)(C++)(甲级)

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9
Sample Output:

-999,991


#include <cstdio>
#include <cstring>
#include <cmath>

int main()
{
	int a = 0, b = 0;
	scanf("%d %d", &a, &b);
	int sum = a + b;
	int S[5] = { 0 };//辅助栈
	int top = -1;//栈顶指针
	if (!sum) { printf("0"); return 0; }//和为0直接输出了
	if (sum < 0) { printf("-"); sum = -sum; }//和为负数先输出符号,之后正负格式统一
	while (sum)
	{
		S[++top] = sum % 1000;
		sum /= 1000;
	}
	printf("%d", S[top--]);//第一个逗号之前不需要补零
	while (top >= 0) printf(",%03d", S[top--]);//注意输出格式
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值