PAT (Advanced Level) Practice A1085 Perfect Sequence (25 分)(C++)(甲级)(排序,二分法)(双指针)(两种方法)

1085 Perfect Sequence (25 分)
Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105) is the number of integers in the sequence, and p (≤10​9​​ ) is the parameter. In the second line there are N positive integers, each is no greater than 10​9.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:

8

//B1030英文版
//https://blog.csdn.net/m0_37454852/article/details/86523186

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

long long int p, A[100010] = {0};//因为中间有乘积,可能会越界,改用long long存储
int N, i, pos, max_len = 0;

int first_over(int left, long long int temp)//二分法查找第一个大于p*A[i]的位置
{
    if(A[N-1] <= temp) return N;
    int l, r, mid;
    for(l=left, r=N-1; l<r; )
    {
        mid = l+(r-l)/2;
        if(A[mid] <= temp) l = mid+1;
        else r = mid;
    }
    return l;
}

int main()
{
    scanf("%d %lld", &N, &p);
    for(i=0; i<N; i++)scanf("%lld", &A[i]);
    sort(A, A+N);//sort两个参数默认升序排序
    for(i=0; i<N-max_len; i++)
    {
        pos = first_over(i+1, p*A[i]);//(或可用C++库函数)pos = upper_bound(A+i+1, A+N, p*A[i]) - A;
        max_len = max(max_len, pos-i);
    }
    printf("%d", max_len);
    return 0;
}

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
#include <ctime>

long long int D[100010] = {0};

int main()
{
    long long int N, p, m, M, max_len = 0, i, j;
    scanf("%lld %lld", &N, &p);
    for(int i=0; i<N; i++)
    {
        scanf("%lld", &D[i]);
    }
    sort(D, D+N);//升序排序
    for(i=0, j=0; i<N-max_len && j<N; i++)
    {
        while(j<N && D[j] <= D[i]*p)
        {
            j++;
            max_len = max(max_len, j-i);
        }
    }
    printf("%lld", max_len);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值