PAT (Advanced Level) Practice A1089 Insert or Merge (25 分)(C++)(归并排序、插入排序)

1089 Insert or Merge (25 分)
According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

//B1035 插入与归并 英文版
//https://blog.csdn.net/m0_37454852/article/details/86561587

//插入的特点是:前半部分有序,后半部分则与初始序列相同
//而归并的后半部分则不一定与初始序列相同
//由于结果唯一,故可根据此特点来区分插入和归并

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
#include <ctime>
#include <cmath>

int N, I[110] = {0}, P[110] = {0}; //初始序列和部分排序后的序列

bool isSame()//判断I是否和P一样
{
    int i=0;
    while(i<N && I[i] == P[i]) i++;
    if(i == N) return true;
    return false;
}

int main()
{
    int i, j;
    scanf("%d", &N);
    for(i=0; i<N; i++) scanf("%d", &I[i]);
    for(i=0; i<N; i++) scanf("%d", &P[i]);
    for(i=1; i<N && P[i] >= P[i-1]; i++);//插入排序,前面是排好序的,后面是与初始序列相同
    for(j=i; j<N && I[j] == P[j]; j++);
    if(j == N)//后半部分相同,则为插入排序
    {
        printf("Insertion Sort\n");
        for(; i && P[i] < P[i-1]; i--) swap(P[i], P[i-1]);//对P再进行一次插入排序
    }
    else//否则为归并排序
    {
        printf("Merge Sort\n");
        int step=2;//归并步长
        for(; !isSame(); step *= 2)//把I归并,直到I和P相同时退出;计算得P最后一次步长是多少
        {
            for(int i=0; i<N; i+=step) sort(I+i, I+min(N, i+step));//对I进行一次归并排序
        }
        for(i=0; i<N; i+=step) sort(P+i, P+min(N, i+step));//对P再进行一次归并排序
    }
    printf("%d", P[0]);//打印输出
    for(i=1; i<N; i++) printf(" %d", P[i]);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
C++中的归并排序是一种经典的排序算法,它采用分治的思想,将待排序的数组不断地分割成更小的子数组,然后再将这些子数组合并成有序的数组。下面是C++中归并排序的实现: ```cpp #include <iostream> using namespace std; // 合并两个有序数组 void merge(int arr[], int left, int mid, int right) { int n1 = mid - left + 1; int n2 = right - mid; // 创建临时数组 int L[n1], R[n2]; // 将数据复制到临时数组 for (int i = 0; i < n1; i++) L[i] = arr[left + i]; for (int j = 0; j < n2; j++) R[j] = arr[mid + 1 + j]; // 合并临时数组 int i = 0, j = 0, k = left; while (i < n1 && j < n2) { if (L[i] <= R[j]) { arr[k] = L[i]; i++; } else { arr[k] = R[j]; j++; } k++; } // 复制剩余元素 while (i < n1) { arr[k] = L[i]; i++; k++; } while (j < n2) { arr[k] = R[j]; j++; k++; } } // 归并排序 void mergeSort(int arr[], int left, int right) { if (left < right) { int mid = left + (right - left) / 2; // 分割数组 mergeSort(arr, left, mid); mergeSort(arr, mid + 1, right); // 合并数组 merge(arr, left, mid, right); } } int main() { int arr[] = {12, 11, 13, 5, 6, 7}; int n = sizeof(arr) / sizeof(arr[0]); cout << "原始数组:"; for (int i = 0; i < n; i++) cout << arr[i] << " "; cout << endl; mergeSort(arr, 0, n - 1); cout << "排序后的数组:"; for (int i = 0; i < n; i++) cout << arr[i] << " "; cout << endl; return 0; } ``` 这段代码实现了归并排序算法。首先,我们定义了一个`merge`函数,用于合并两个有序数组。然后,我们定义了`mergeSort`函数,用于递归地分割和合并数组。最后,在`main`函数中,我们创建一个待排序的数组,并调用`mergeSort`函数进行排序

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值