甲级PAT 1089 Insert or Merge (25 分)(归并排序,插入排序)

1089 Insert or Merge (25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

题目要求 

给出一个序列以及序列进行排序的中间步骤,说明是用何种排序方式(归并排序或插入排序)以及用这种排序方式的下一步排序情况

解题思路

对原序列进行归并排序(非递归方式),每执行一步判断结果是否和给出的中间步骤一致,如果一致,则为归并排序(设置flag为1),然后继续运算一步,如果归并排序结束仍未有和中间步骤一样的(此时flag为0),就按照插入排序方法,对每一步排序结果与中间步骤进行比较,找到后继续运算一步

注意

这里插入排序有个坑就是,下一步的排序结果和中间步骤相同,此时要继续向后运算,直到和中间步骤不同

10
3 1 2 8 7 5 9 4 6 0
1 2 3 5 7 8 9 4 6 0
Insertion Sort
1 2 3 5 7 8 9 4 6 0

应输出
Insertion Sort
1 2 3 4 5 7 8 9 6 0

完整代码

#include<bits/stdc++.h>
using namespace std;
int n,a[110],b[110],c[110],flag=0;

int check(){
	int i;
	for(i = 1; i <= n; i++){
		if(b[i] != c[i]) return 0;
	}
	return 1;
}

void merge(int l1, int r1, int l2, int r2){
	int i = l1, j = l2;
	int temp[110], index = 0;
	while(i <= r1 && j <= r2){
		if(c[i] <= c[j]){
			temp[index++] = c[i++];
		}else{
			temp[index++] = c[j++];
		}
	}
	while(i <= r1) temp[index++] = c[i++];
	while(j <= r2) temp[index++] = c[j++];
	for(i = 0; i < index; i++){
		c[l1 + i] = temp[i];
	}
}

void mergeSort(){
	int step,i;
	for(step = 2; step / 2 <=n; step *= 2){
		for(i = 1; i <= n; i += step){
			int mid = i + step / 2 -1;
			if(mid + 1 <= n){
				merge(i, mid, mid+1, min(i + step - 1, n));
			}
		}
		if(check()){
			flag = 1;
			step *= 2;
			for(i = 1; i <= n; i += step){
				int mid = i + step / 2 -1;
				if(mid + 1 <= n){
					merge(i, mid, mid+1, min(i + step - 1, n));
				}
			}
			break;
		}
	}
}

void insertSort(){
	int i,j,k;
	for(i = 2; i <= n; i++){
		int temp = c[i];
		j = 1;
		while(j < i && c[i] >= c[j]) j++;
		for(k = i - 1; k >= j; k--){
			c[k+1] = c[k];
		} 
		c[j] = temp;
		if(check()){
			while(check()){
				i++;
				temp = c[i];
				j = 1;
				while(j < i && c[i] >= c[j]) j++;
				for(k = i - 1; k >= j; k--){
					c[k+1] = c[k];
				} 
				c[j] = temp;
				if(!check()) break;
			}
			break;
			
		}
	}
}

int main(){
	int i;
	cin>>n;
	for(i = 1; i <= n; i++) cin >> a[i];
	for(i = 1; i <= n; i++) cin >> b[i];
	memset(c,0,sizeof(a));
	memcpy(c,a,(n+1)*sizeof(int));
	mergeSort();
	if(flag == 1){
		cout<<"Merge Sort"<<endl;
	}else{
		cout<<"Insertion Sort"<<endl;
		memcpy(c,a,(n+1)*sizeof(int));
		insertSort();	
	}
	for(i = 1; i <= n; i++){
		if(i == 1) cout << c[i];
		else cout << " " << c[i];
	} 
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值