PAT (Advanced Level) Practice A1093 Count PAT's (25 分)(C++)(甲级)(递推思想)

1093 Count PAT’s (25 分)
The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5 characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT
Sample Output:

2

//本题只需要计算每个A之前P的个数与其之后的T的个数的乘积的累加和即可 //即Pi*Ti(i从1到Anum)的累加和
//在计算Pi和Ti时可以用递推思想,本题表现在程序里即Pi、Ti不清零,继续计算下一个

//B1040 有几个PAT 英文版
//https://blog.csdn.net/m0_37454852/article/details/86566274
using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

int main()
{
    int cnt = 0, Tnum = 0, Px = 0, Tx = 0;
  char S[100010] = {0};//存放字符串
    scanf("%s", S);
    int N = strlen(S);
    for(int i=0; i<N; i++)
    {
        if(S[i] == 'T') Tnum++;//T的总数
    }
    for(int i=0; i<N; i++)
    {
        if(S[i] == 'P') Px++;//某一个A之前P的个数
        if(S[i] == 'T') Tx++;//某一个A之前T的个数;则Tnum - Tx即为该A之后T的个数
        if(S[i] == 'A')
        {
            cnt += Px*(Tnum - Tx);//计算由该A可以组成的PAT的个数;由于S长度小于10^5,故累加不会导致越界
            cnt %= 1000000007;//按题意取余,避免溢出
        }
    }
    printf("%d", cnt);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值