usaco - Superprime Rib

Butchering Farmer John's cows always yields the best prime rib. You can tell prime ribs by looking at the digits lovingly stamped across them, one by one, by FJ and the USDA. Farmer John ensures that a purchaser of his prime ribs gets really prime ribs because when sliced from the right, the numbers on the ribs continue to stay prime right down to the last rib, e.g.:

     7  3  3  1

The set of ribs denoted by 7331 is prime; the three ribs 733 are prime; the two ribs 73 are prime, and, of course, the last rib, 7, is prime. The number 7331 is called a superprime of length 4.

Write a program that accepts a number N 1 <=N<=8 of ribs and prints all the superprimes of that length.

The number 1 (by itself) is not a prime number.

PROGRAM NAME: sprime

INPUT FORMAT

A single line with the number N.

SAMPLE INPUT (file sprime.in)

4

OUTPUT FORMAT

The superprime ribs of length N, printed in ascending order one per line.

SAMPLE OUTPUT (file sprime.out)

2333
2339
2393
2399
2939
3119
3137
3733
3739
3793
3797
5939
7193
7331
7333
7393
用循环做很快就超时了= =
参考网上的代码(用dfs写)
/*
ID:
PROG: sprime
LANG: C++
*/
#include<iostream>
#include<cstdio>
#include<fstream>
#include<cmath>

int N;
int a[]={2,3,5,7};
//判断是否为素数
int prime(int n){
    if(n==2)return 1;
    if(n%2==0)return 0;
    for(int i=3;i*i<=n;i++){
        if(n%i==0)return 0;
    }
    return 1;
}
//从左到右判断
void dfs(int i,int j){
    if(!prime(i)||j>N)return ;//如果i不是素数或者j大于N无返回值
    if(j==N&&prime(i))printf("%d\n",i);//如果是素数且j==N;则打印
    for(int k=1;k<=9;k+=2){//末位为偶数的都不是素数不用考虑
        dfs(i*10+k,j+1);
    }
}
int main(){
    freopen("sprime.in","r",stdin);
    freopen("sprime.out","w",stdout);
    scanf("%d",&N);
    for(int i=0;i<4;i++){
        dfs(a[i],1);
    }
}
这样从左到右生成数且判断是不是素数不是return ;而且每个数的左数第一个数都是2,3,5,7中的,大大节省了时间。
好吧,本菜鸟还是对dfs不是很熟悉。加油加油!


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值