usaco - Zero Sum

Consider the sequence of digits from 1 through N (where N=9) in increasing order: 1 2 3 ... N.

Now insert either a `+' for addition or a `-' for subtraction or a ` ' [blank] to run the digits together between each pair of digits (not in front of the first digit). Calculate the result that of the expression and see if you get zero.

Write a program that will find all sequences of length N that produce a zero sum.

PROGRAM NAME: zerosum

INPUT FORMAT

A single line with the integer N (3 <= N <= 9).

SAMPLE INPUT (file zerosum.in)

7

OUTPUT FORMAT

In ASCII order, show each sequence that can create 0 sum with a `+', `-', or ` ' between each pair of numbers.

SAMPLE OUTPUT (file zerosum.out)

1+2-3+4-5-6+7
1+2-3-4+5+6-7
1-2 3+4+5+6+7
1-2 3-4 5+6 7
1-2+3+4-5+6-7
1-2-3-4-5+6+7
k:表示数字几

sum:表示当前的和

num:表示当前加到的数

eg:dfs(2,1,2)表示当前加完了1,该加数2了

犯的错误:

之前写dfs结束条件的时候写成

if(k==n&&sum+num==0){
    puts(a);
    return ;
}
这样是错误的,因为(k==n&&sum+num!=0)这个情况没有考虑,k会一直增大。

所以dfs要保证有结束的条件。

另外初始化字符数组用memset。

/*
ID:
LANG:C++
PROG:zerosum
*/
#include<iostream>
#include<cstdio>
#include<cstring>
char a[50];
int n;
void dfs(int k,int sum,int num){
    if(k==n){
        if(sum+num==0)puts(a);
        return ;
    }
    a[2*k-1]=' ';
    dfs(k+1,sum,num>0?num*10+k+1:10*num-k-1);
    a[2*k-1]='+';
    dfs(k+1,sum+num,k+1);
    a[2*k-1]='-';
    dfs(k+1,sum+num,-k-1);
}

int main()
{
    freopen("zerosum.in", "r", stdin);
    freopen("zerosum.out", "w", stdout);
    scanf("%d",&n);
    memset(a,0,sizeof(a));
    for(int i=0;i<n;i++){
        a[2*i]=i+'1';
    }
    dfs(1,0,1);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值