第五章 - uva - 540 - queue

Queues and Priority Queues are data structures which are known to most computer scientists. TheTeam Queue, however, is not so well known, though it occurs often in everyday life. At lunch time thequeue in front of the Mensa is a team queue, for example.In a team queue each element belongs to a team. If an element enters the queue, it first searchesthe queue from head to tail to check if some of its teammates (elements of the same team) are alreadyin the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tailand becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements areprocessed from head to tail in the order they appear in the team queue.Your task is to write a program that simulates such a team queue.

Input

The input file will contain one or more test cases. Each test case begins with the number of teamst (1 ≤ t ≤ 1000). Then t team descriptions follow, each one consisting of the number of elementsbelonging to the team and the elements themselves. Elements are integers in the range 0..999999. Ateam may consist of up to 1000 elements.Finally, a list of commands follows. There are three different kinds of commands:

• ENQUEUE x — enter element x into the team queue

• DEQUEUE — process the first element and remove it from the queue

• STOP — end of test caseThe input will be terminated by a value of 0 for t.

Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementationof the team queue should be efficient: both enqueing and dequeuing of an element shouldonly take constant time.

Output

For each test case, first print a line saying ‘Scenario #k’, where k is the number of the test case. Then,for each ‘DEQUEUE’ command, print the element which is dequeued on a single line. Print a blank lineafter each test case, even after the last one.

Sample Input

2

3 101 102 103

3 201 202 203

ENQUEUE 101

ENQUEUE 201

ENQUEUE 102

ENQUEUE 202

ENQUEUE 103

ENQUEUE 203

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

STOP

2

5 259001 259002 259003 259004 259005

6 260001 260002 260003 260004 260005 260006

ENQUEUE 259001

ENQUEUE 260001

ENQUEUE 259002

ENQUEUE 259003

ENQUEUE 259004

ENQUEUE 259005

DEQUEUE

DEQUEUE

ENQUEUE 260002

ENQUEUE 260003

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

STOP

0

Sample Output

Scenario #1

101

102

103

201

202

203

Scenario #2

259001

259002

259003

259004

259005

260001

注:queue<int> q,q2[1005];

q是队伍的队列

q2[i]是队伍i的队列

#include<iostream>
#include<cstdio>
#include<map>
#include<string>
#include<algorithm>
#include<queue>

using namespace std;
int cas=0;
int main(){
    int dn,n,m;
    while(cin>>dn){
        if(dn==0)break;
        map<int,int> peo;
        cas++;
        cout<<"Scenario #"<<cas<<endl;
        for(int i=0;i<dn;i++){//几队
            cin>>n;
            for(int j=0;j<n;j++){//几个人
                cin>>m;
                peo[m]=i;//编号为m的人在哪一队里
            }
        }
        string str;
        int x;
        queue<int> q,q2[1005];//队i的队列
        while(cin>>str){
            if(str=="STOP")break;
            if(str=="ENQUEUE"){
                cin>>x;
                int t=peo[x];//得到队号
                if(q2[t].empty())q.push(t);//还没有队号为t的人入队
                q2[t].push(x);
            }
            if(str=="DEQUEUE"){
                int t=q.front();
                cout<<q2[t].front()<<endl;
                q2[t].pop();
                if(q2[t].empty())q.pop();
            }
        }
        cout<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值