第四章 - Hangman Judge - uav489

In “Hangman Judge,” you are to write a program that judges a series of Hangman games. For eachgame, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic gameof hangman, and are given as follows:

1. The contestant tries to solve to puzzle by guessing one letter at a time.

2. Every time a guess is correct, all the characters in the word that match the guess will be “turnedover.” For example, if your guess is ‘o’ and the word is “book”, then both ‘o’s in the solution willbe counted as “solved”.

3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, whichneeds 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

______| || O| /|\| || / \__|_| |______|_________|4. If the drawing of the hangman is completed before the contestant has successfully guessed all thecharacters of the word, the contestant loses.5. If the contestant has guessed all the characters of the word before the drawing is complete, thecontestant wins the game.6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.Your task as the “Hangman Judge” is to determine, for each game, whether the contestant wins,loses, or fails to finish a game.InputYour program will be given a series of inputs regarding the status of a game. All input will be in lowercase. The first line of each section will contain a number to indicate which round of the game is beingplayed; the next line will be the solution to the puzzle; the last line is a sequence of the guesses madeby the contestant. A round number of ‘-1’ would indicate the end of all games (and input).OutputThe output of your program is to indicate which round of the game the contestant is currently playingas well as the result of the game. There are three possible results:You win.You lose.You chickened out.

Sample Input1cheesechese2cheeseabcdefg3cheeseabcdefgij-1Sample OutputRound 1You win.Round 2You chickened out.Round 3You lose.

分析:看题是觉得很难,但是仔细分析后就会找到简单的方法

注意:猜一个已经猜过的答案也算错!

设全局变量fail和win,通过fail和win来判断输赢

通过使猜对的字符变成' '来控制,猜对一个第二次猜的数时的情况

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;
char a[100],b[100];
int n,rnd;
int win,fail,len1,len2,cnt;

void guess(char ch){
    int flag=0;
    for(int i=0;i<strlen(a);i++){//把与ch相等的字符串都变成空格
        if(a[i]==ch){len1--;a[i]=' ';flag=1;}
    }
    if(!flag)cnt--;
    if(cnt<=0)fail=1;
    if(!len1)win=1;
}

int main(){
    while(scanf("%d%s%s",&rnd,a,b)==3&&rnd!=-1){
        printf("Round %d\n",rnd);
        win=0;fail=0;
        len1=strlen(a);
        len2=strlen(b);
        cnt=7;
        for(int i=0;i<len2;i++){
            guess(b[i]);
            if(win||fail)break;
        }
        if(win)printf("You win.\n");
        else if(fail)printf("You lose.\n");
        else printf("You chickened out.\n");
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值