Find them, Catch them - 并查集

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4
Sample Output
Not sure yet.
In different gangs.
In the same gang.

分析:

通过分析题可知有两个集合,可以把pre数组开到原来的两倍

D a b

每次把a与b+n合并,b与a+n合并

例如D 1 2,D 3 4,D 1 3

1与2+n,3+n

2与1+n

3与4+n,1+n

4与3+n

可见1与4同根节点,2与3同根节点(就是这么巧合)!

注意输出的时候,根节点相同的一定同一类,f(a)与f(b+n)相等,即a和b的敌人一类,即a与b相克。剩下的情况就是不能确定的情况了。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

int pre[200004];

int f(int x){
    if(x==pre[x])return x;
    pre[x]=f(pre[x]);
    return pre[x];
}

void link(int a,int b){
    int root1=f(a),root2=f(b);
    if(root1!=root2){
        pre[root1]=root2;
    }
}

int main(){
    int t,n,m,a,b;
    char s[5];
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        for(int i=1;i<=2*n;i++){
            pre[i]=i;
        }
        while(m--){
            scanf("%s%d%d",&s,&a,&b);
            if(s[0]=='D'){
                link(a,b+n);
                link(b,a+n);
            }

            else{
                int root1=f(a),root2=f(b);
                if(root1==root2)printf("In the same gang.\n");
                else if(root1==f(b+n))printf("In different gangs.\n");
                else printf("Not sure yet.\n");
            }
        }
    }
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值