Curling 2.0 - poj3009 - dfs

Curling 2.0

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25824 Accepted: 10361

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

球的运动规律:

球的起点是2,终点是3,障碍物是1,空地是0

1、只能水平、竖直运动,不能斜线运动。

a、碰到障碍物的时候,停在障碍物旁边的位置,障碍物消失

b、没碰到障碍物时沿运动方向一直走

c、走出地图则失败

d、走到重点则成功

(妈耶,wa了一天到现在才发现输入时,先输入列数,后输入行数,qwq)

思路:

要注意的是碰壁后,步数step++,mape[i][j]=0然后从这个状态开始递归,dfs(nx-dx[i],ny-dy[i]),然后要恢复步数和地图,因为在本次递归中,还有其他方向等着去尝试,对于本次递归来说不能改变地图和步数啊。

dfs得到多种到终点的步数,再用mymin记录最小的步数。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int mape[25][25];
int n,m,sx,sy,ex,ey;
int dx[]={-1,0,1,0},dy[]={0,1,0,-1};
int step,mymin;

void dfs(int x,int y){
	if(step>10)return ;//次数超过10则不合格 
	for(int i=0;i<4;i++){
		int nx=x+dx[i];
		int ny=y+dy[i];
		int flag=0;
		while(nx>=0&&nx<n&&ny>=0&&ny<m&&mape[nx][ny]!=1){//能走就一直直线行走 
			flag=1;
			if(nx==ex&&ny==ey){//到终点了,mymin记录最少的步数 
				mymin=min(mymin,step);
			}
			nx+=dx[i];
			ny+=dy[i];
		}
		if(mape[nx][ny]==1&&flag){//碰壁 
			step++;
			mape[nx][ny]=0;
			dfs(nx-dx[i],ny-dy[i]);
			step--; 
			mape[nx][ny]=1;
		}
	}
}

int main(){
	while(scanf("%d%d",&m,&n)!=EOF){
		if(n==0&&m==0)break;
		memset(mape,0,sizeof(mape));
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				scanf("%d",&mape[i][j]);
				if(mape[i][j]==2){sx=i;sy=j;}
				if(mape[i][j]==3){ex=i;ey=j;}
			}
		}
		step=1;//初始抛出去也算1次 
		mymin=1000000;
		dfs(sx,sy);
		if(mymin>10)cout<<-1<<endl;
		else cout<<mymin<<endl;
	}
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值