A Chess Game - poj2425 - 博弈论(sg函数)

A Chess Game

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 4669 Accepted: 1861

Description

Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again. 

Do you want to challenge me? Just write your program to show your qualification!

Input

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.

Output

There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.

Sample Input

4
2 1 2
0
1 3
0
1 0
2 0 2
0

4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0

Sample Output

WIN
WIN
WIN
LOSE
WIN

Hint

Huge input,scanf is recommended.

Source

PKU Monthly,CHEN Shixi(xreborner)

题意:

给你n个点,然后n行,每行表述的是点n-1所连接的点,(单向的),然后是问题,每个问题占1行,每行的第一个数是棋子的个数num,然后num个数表述的是棋子在哪个点上,A,B轮流移动棋子,每次只能走1个点,谁先不能走谁输。

思路:

这不就是sg函数的应用吗,num个棋子就是num个子游戏,总游戏的sg值是子游戏sg值的异或。

求子游戏sg值时,当棋子走到一个点,这个点没有可走的点了,sg值为0

否则,用深搜递归地求它走到不同点(不同后继状态)的sg值,就可得该点的sg值~

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<vector>
using namespace std;
const int N=1005;
vector<int> G[N];
int n,sg[N];

int dfs(int u){
	if(sg[u]!=-1)return sg[u];
	int vis[N]={0};
	for(int i=0;i<G[u].size();i++){
		vis[dfs(G[u][i])]=1;
	}
	for(int i=0;;i++){
		if(!vis[i])return sg[u]=i;
	}
}

int main(){
	while(scanf("%d",&n)!=EOF){
		memset(sg,-1,sizeof(sg));
		for(int i=0;i<n;i++){
			int k,a;
			scanf("%d",&k);
			if(k==0)sg[i]=0;
			for(int j=0;j<k;j++){
				scanf("%d",&a);
				G[i].push_back(a);
			}
		}
		int m,t;
		while(scanf("%d",&m)!=EOF){
			if(m==0)break;
			int x=0;
			for(int i=0;i<m;i++){
				scanf("%d",&t);
				x^=dfs(t);
			}
			if(x!=0)printf("WIN\n");
			else printf("LOSE\n");
		} 
		for(int i=0;i<n;i++)G[i].clear();
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值