杭电 acm 1004 Let the Balloon Rise

Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 135888    Accepted Submission(s): 53700






Problem Description


Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.


This year, they decide to leave this lovely job to you. 




 




Input


Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.


A test case with N = 0 terminates the input and this test case is not to be processed.




 




Output


For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.




 




Sample Input


5
green
red
blue
red
red
3
pink
orange
pink
0




 




Sample Output


red
pink




 

#include<iostream>
#include<cstring>
#include<string.h>
#include<string>
using namespace std;
void max(int a[1001],int &m,int &n)
{
	for(int i=0;i<=n;i++)
	{
		if(a[i]>a[m])
		 m=i;
	}
}
int main()
{
	char a[1001][16],b[15];
	int n;
	while(cin>>n&&n!=0)
	{
		int l=0,k=0,m[1001]={0};
		for(int i=0;i<n;i++)
		{
			cin>>b;
			l=k;
			for(int j=0;j<=l;j++)
			{
			 if(strcmp(a[j],b)==0)
			 {
				 m[j]++;
				 break;
			 }
			 if(j==l)
			 {
			 	strcpy(a[j],b);
			 	k++;
			  } 
		    }
		}
		int o=0;
		max(m,o,k);
		cout<<a[o]<<endl;
	}
	return 0; 
}




Author


WU, Jiazhi



查找出重复最多的字符串
新学函数
strcmp 判断字符串是否相等
strcpy 给字符串赋值
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值