poj1990 - MooFest - 两个树状数组

MooFest

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10529 Accepted: 4807

Description

Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing.

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)).

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume.

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location.

Output

* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows.

Sample Input

4
3 1
2 5
2 6
4 3

Sample Output

57

思路:

这道题 意思是,许多点散落在坐标轴上,每个还有一个对应的v值,求所有点两两之间的运算结果之和。

两个点运算的过程是:max{vi,vj}*(xi-xj)

观看数据范围是:20000,模拟肯定会超时,必须想到巧妙地办法求解。

我们发现每次运算成的都是较大的v值,那么我们先把v值按照从小到大的顺序排列,那么每次计算到一个点乘的v值就是这个点对应的vi。

1. 用两个树状数组,一个记录比xi小的点的个数num,一个记录比xi小的点的位置之和l

与xi点距离差的和是:num*xi-l

2.此时比xi大的点的个数是:i-num,(点xi+1,xi+2...还未更新),比xi大的点的位置之和是:sum(20000)-l

与xi点距离差的和是:sum(20000)-l-(i-num)*xi

(num*xi-l+sum(20000)-l-(i-num)*xi)*vi  就是每次更新的值

代码如下:

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<cstring>
#include<set>
#include<map>
#include<queue>
#include<vector>
#define ll long long
using namespace std;
const int N=2e4+10,mod=1e9+7;
const int INF=0x3f3f3f3f;

struct A{
    ll v,x;
}a[N];
ll n,cN[N],cL[N];

bool cmp(A a,A b){
    return a.v<b.v;
}

ll lowbit(ll x){
    return x&(-x);
}

ll sum(ll x,ll c[]){
    ll res=0;
    while(x>0){
        res+=c[x];
        x-=lowbit(x);
    }
    return res;
}

void update(ll x,ll m,ll c[]){
    while(x<=20000){
        c[x]+=m;
        x+=lowbit(x);
    }
}

int main(){
    scanf("%lld",&n);
    ll L=0;
    for(int i=0;i<n;i++){
        scanf("%lld%lld",&a[i].v,&a[i].x);
        L+=a[i].x;
    }
    sort(a,a+n,cmp);
    ll res=0;
    update(a[0].x,1,cN);
    update(a[0].x,a[0].x,cL);
    for(int i=1;i<n;i++){
        ll num=sum(a[i].x,cN);
        ll lq=sum(a[i].x,cL);
        ll lh=sum(20000,cL)-lq;
        res+=a[i].v*(num*a[i].x-lq+lh-(i-num)*a[i].x);
        update(a[i].x,1,cN);
        update(a[i].x,a[i].x,cL);
    }
    printf("%lld\n",res);
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值