[POJ](3268)Silver Cow Party ---最短路径(图)

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23762 Accepted: 10850

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

解题新知:
①:题意:一头牛x在家举办party,其他牛要去找它家参加聚会,牛儿们都比较懒,要走最短的路线才行,而且当它们参加完聚会后还要会自己的家,并且还是走最短的路线。问:那头牛走的最短路径是所有牛中最大的?
②:思路:求两次最短路径,去的时候是i到x的最短路径,来的时候是x到i的最短路径。那么我们可以在求完去的时候的最短路径后,翻转map,将map的行和列对换(即map[i][x]->map[x][i])。最后将每头牛去的dist[i]和来的distBack[i]相加,求最大即可。好题!

AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
int n,m,x;
int mmap[1005][1005];
bool vis[1005];
bool visback[1005];
int dist[1005];
int distback[1005];
using namespace std;
void dijkstra()
{
    for(int i=1;i<=n;i++)
    {
        dist[i]=mmap[i][x];
        distback[i]=mmap[x][i];
    }
    int k;
    int mmin;
    for(int i=1;i<=n;i++)
    {
        mmin=INF;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && dist[j]<mmin)
            {
                mmin=dist[j];
                k=j;
            }
        }
        vis[k]=true;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&dist[k]+mmap[j][k]<dist[j])
                dist[j]=dist[k]+mmap[j][k];
        }
    }
    for(int i=1;i<=n;i++)
    {
        mmin=INF;
        for(int j=1;j<=n;j++)
        {
            if(!visback[j] && distback[j]<mmin)
            {
                mmin=distback[j];
                k=j;
            }
        }
        visback[k]=true;
        for(int j=1;j<=n;j++)
        {
            if(!visback[j]&&distback[k]+mmap[k][j]<distback[j])
                distback[j]=distback[k]+mmap[k][j];
        }
    }
}
int main()
{
    int u,v,w;
    while(scanf("%d %d %d",&n,&m,&x)!=EOF)
    {
        //memset(mmap,0x3f,sizeof(mmap));
        memset(dist,0,sizeof(dist));
        memset(distback,0,sizeof(distback));
        memset(vis,false,sizeof(vis));
        memset(visback,false,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(i!=j)
                    mmap[i][j]=INF;
                else
                    mmap[i][j]=0;
            }
        }
        while(m--)
        {
            scanf("%d %d %d",&u,&v,&w);
            if(w<mmap[u][v])
                mmap[u][v]=w;
        }
        dijkstra();
        int mmax=-1;
        for(int i=1;i<=n;i++)
        {
            mmax=max(mmax,dist[i]+distback[i]);
        }
        printf("%d\n",mmax);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值