Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 23762 | Accepted: 10850 |
Description
One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.
Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.
Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?
Input
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Sample Input
4 8 2 1 2 4 1 3 2 1 4 7 2 1 1 2 3 5 3 1 2 3 4 4 4 2 3
Sample Output
10
Hint
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
int n,m,x;
int mmap[1005][1005];
bool vis[1005];
bool visback[1005];
int dist[1005];
int distback[1005];
using namespace std;
void dijkstra()
{
for(int i=1;i<=n;i++)
{
dist[i]=mmap[i][x];
distback[i]=mmap[x][i];
}
int k;
int mmin;
for(int i=1;i<=n;i++)
{
mmin=INF;
for(int j=1;j<=n;j++)
{
if(!vis[j] && dist[j]<mmin)
{
mmin=dist[j];
k=j;
}
}
vis[k]=true;
for(int j=1;j<=n;j++)
{
if(!vis[j]&&dist[k]+mmap[j][k]<dist[j])
dist[j]=dist[k]+mmap[j][k];
}
}
for(int i=1;i<=n;i++)
{
mmin=INF;
for(int j=1;j<=n;j++)
{
if(!visback[j] && distback[j]<mmin)
{
mmin=distback[j];
k=j;
}
}
visback[k]=true;
for(int j=1;j<=n;j++)
{
if(!visback[j]&&distback[k]+mmap[k][j]<distback[j])
distback[j]=distback[k]+mmap[k][j];
}
}
}
int main()
{
int u,v,w;
while(scanf("%d %d %d",&n,&m,&x)!=EOF)
{
//memset(mmap,0x3f,sizeof(mmap));
memset(dist,0,sizeof(dist));
memset(distback,0,sizeof(distback));
memset(vis,false,sizeof(vis));
memset(visback,false,sizeof(vis));
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(i!=j)
mmap[i][j]=INF;
else
mmap[i][j]=0;
}
}
while(m--)
{
scanf("%d %d %d",&u,&v,&w);
if(w<mmap[u][v])
mmap[u][v]=w;
}
dijkstra();
int mmax=-1;
for(int i=1;i<=n;i++)
{
mmax=max(mmax,dist[i]+distback[i]);
}
printf("%d\n",mmax);
}
return 0;
}