POJ 3268 Silver Cow Party--正反Dijkstra

🚪

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N
is going to attend the big cow party to be held at farm #X (1 ≤ X ≤
N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads
connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of
time to traverse.

Each cow must walk to the party and, when the party is over, return to
her farm. Each cow is lazy and thus picks an optimal route with the
shortest time. A cow’s return route might be different from her
original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend
walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2…M+1: Line i+1 describes road i with three space-separated
integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm
Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

正反走两边即可得到不同位置的最短路径,最后便利所有,找最大值

code

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
int a1[1005][1005],a2[1005][1005];
int d1[1005],d2[1005];
int book[1005];
int n,m,x;
int d() {
	memset(book,0,sizeof book);
	memset(d1,0x3f,sizeof d1);
	d1[x]=0;
	for(int i=1; i<=n; i++) {
		int t=-1;
		for(int j=1; j<=n; j++) {
			if(!book[j]&&(t==-1||d1[t]>d1[j]))
				t=j;
		}
		book[t]=1;
		for(int j=1; j<=n; j++)
			d1[j]=min(d1[j],d1[t]+a1[t][j]);
	}
}
int dd() {
	memset(book,0,sizeof book);
	memset(d2,0x3f,sizeof d2);
	d2[x]=0;
	for(int i=1; i<=n; i++) {
		int t=-1;
		for(int j=1; j<=n; j++) {
			if(!book[j]&&(t==-1||d2[t]>d2[j]))
				t=j;
		}
		book[t]=1;
		for(int j=1; j<=n; j++)
			d2[j]=min(d2[j],d2[t]+a2[t][j]);
	}
}
int main() {
	memset(a1,0x3f,sizeof a1);
	memset(a2,0x3f,sizeof a2);
	cin>>n>>m>>x;
	for(int i=1; i<=n; i++)a1[i][i]=a2[i][i]=0; //自己到自己=0
	while(m--) {
		int x,y,z;
		scanf("%d%d%d",&x,&y,&z);
		a1[x][y]=min(a1[x][y],z);
		a2[y][x]=min(a2[y][x],z);
	}
	d();
	dd();
	int c=0;
	for(int i=1; i<=n; i++)c=max(c,d1[i]+d2[i]);
	cout<<c;
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值