[POJ](3723)Conscription ---- 最小生成树(Kruskal)

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

题意:
有一个国王想要征兵,征一个人的费用是10000,现在有n个女孩,m个男孩,r种关系,如果女孩和男孩有关系d,那么这么关系d可以使征兵费用变为10000-d。一个关系
只能使用一次,求最小的花费。

思路:
典型的最小生成树问题,需要注意的是要注意关系d越大时,花费最小。那么我们可以使d变为-d,然后求根据这个负的权值构造最小生成树,然后最后的花费就是10000*(n+m)+Kruskal(sum_cost)

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int fa[20005];
int Find(int x)
{
    return x == fa[x]?x:fa[x] = Find(fa[x]);
}
void Union(int x,int y)
{
    int a=Find(x),b=Find(y);
    if(a!=b)
        fa[a] = b;
}
bool same(int x,int y)
{
    return Find(x) == Find(y);
}
struct edge{
    int u,v,cost;
};
bool cmp(edge a,edge b)
{
    return a.cost<b.cost;
}
const int MAX = 50005;
const int C = 10000;
edge e[MAX];
int n,m,r;
int num;
int kruskal()
{
    sort(e,e+r,cmp);
    int ans = 0;
    for(int i=0;i<r;i++)
    {
        edge now = e[i];
        if(!same(now.u,now.v))
        {
            Union(now.u,now.v);
            ans+=(now.cost);
        }
    }
    return ans;
}
int main()
{
    int t;
    /*ios_base::sync_with_stdio(false);
    cin.tie(NULL),cout.tie(NULL);*/
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d %d",&n,&m,&r);
        num = n+m;
        for(int i=0;i<num;i++)
            fa[i] = i;
        int x,y,d;
        for(int i=0;i<r;i++)
        {
            scanf("%d %d %d",&e[i].u,&e[i].v,&e[i].cost);
            e[i].cost = -e[i].cost;
            e[i].v+=n;//注意男孩和女孩要重新编号,因为n,m是分开的,所里要合在一块
        }
        printf("%d\n",10000*num+kruskal());
    }
    return 0;
}
/*
输出外挂会TLE,还是继续scanf,printf吧
Status Accepted
Time 375ms
Memory 1352kB
Length 1266
Lang G++
*/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值